2
$\begingroup$

I'm very new to blender, using it for robotics, so primarily drawing using python very little hand-drawing.

When I am typing in the script editing window in Blender (2.76b in Ubuntu) and my mouse cursor drifts outside this window (worst is the viewport window), the ability to type into the editor window halts. I have to manually push my mouse cursor back in, even if the text cursor (|) is still in the editor window. Is there a way to change this default behavior?

It is particularly annoying if I accidentally type a hotkey (e.g., Z) that changes some basic behavior in the viewport, and I don't know what I did. This is becoming very frustrating and inefficient.

I assume this is also a feature, so you can go do some quick hotkey stuff in the viewport while working on scripting, but I would really like to let my mouse cursor and text editing cursor be in different places, while editing text. That is, I want the text cursor to take all my keyboard events, as is the default in all my other applications.

I have searched online for an answer, posted at blender forum and gotten no response yet: https://blenderartists.org/forum/showthread.php?402785-How-to-type-in-script-editor-window-when-mouse-cursor-elsewhere

$\endgroup$
  • 2
    $\begingroup$ Indeed this "feature" of blender (mouse position sensitive context) is very annoying in the text editor. Alas I do not know of a way to change it. UVed. $\endgroup$ – David Jul 13 '16 at 2:43
  • $\begingroup$ it's the way blender works, it tracks the mouse to know what editor is active and what context will receive keyboard and mouse events. $\endgroup$ – user2816 Jul 13 '16 at 2:44
  • $\begingroup$ I guess I could just maximize the text editor window (stretch it WAAY to the right edge, maybe into my second monitor), minimize the viewport :) Seems draconian, but if it works... $\endgroup$ – neuronet Jul 13 '16 at 2:52
  • $\begingroup$ root I can see this being really useful for all the gui stuff, where your life tends to revolve around the mouse cursor, but for scripting it can be very annoying. $\endgroup$ – neuronet Jul 14 '16 at 2:58
2
$\begingroup$

Well this is a workaround but if you Toggle Fullscreen Area AltF10, then you can type in the text editor with the mouse cursor outside of blender!

animated gif

See my answer for other options for maximizing windows in blender.
However full screen area is the only one that works completely, simply maximizing the text editor the header and info bar still get in the way.

$\endgroup$
  • $\begingroup$ In my system (ubuntu 16) alt-f10 just brings up wireless network menu, but ctrl-up arrow does make current window take up the whole blender main window. Unfortunately even then I still can't type when the mouse is outside the window, like you are doing in the gif. Doesn't work for me. $\endgroup$ – neuronet Jul 14 '16 at 2:57
  • $\begingroup$ well either change the system shortcut or change blender's shortcut, because as I said in my answer "full screen area is the only one that works completely." $\endgroup$ – David Jul 14 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.