1
$\begingroup$

I found out what Open Shading Language was today and was excited to try it out, and it was working at first. But at some point, I found that I could no longer press the "Script Node Update" button either in the Text Editor or in the Shader Editor's script node in order to actually use the scripts. I've tried both Internal and External scripts, and I'm using the Templates, so it's not a syntax error in the OSL Script. I also tried saving the file to see if that was the problem (as before, I was working just on new, unsaved files), but it still didn't work.

I just can't press the update button to actually use the Script node as the button is grayed out. I can't figure out what I did to break it and how to fix it. enter image description here

$\endgroup$
1
  • $\begingroup$ @RobinBetts Wow, okay, that should have been obvious. Thanks, it's working now. Feel free to post that as the answer. $\endgroup$ Jul 4, 2020 at 10:40

1 Answer 1

2
$\begingroup$

OSL scripts will compile only if you are rendering in Cycles, on the CPU.

When both of those are true, an 'Open Shading Language' checkbox becomes available in the Properties region, Render tab, just under 'Device' (CPU)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .