6
$\begingroup$

I'm making a rolling ball animation where the ball will roll around a set of pipes, planes and other objects. I created a spring using the screw modifier and then made a second slightly smaller spring inside it to create a track like effect for my ball to roll on.
When I add the passive object to them, they still will not hold up my ball. The ball falls straight through them.
blender showing the rigid body simulation objects and settings

$\endgroup$
  • 2
    $\begingroup$ On the rigid body collisions try Mesh $\endgroup$ – cegaton Jun 17 '15 at 2:44
  • $\begingroup$ Just went and tried it. Still doesn't work. Thanks for the idea tho. $\endgroup$ – Steven Akers Jun 17 '15 at 7:21
3
$\begingroup$

You need to change the Source and the Shape of the rigid body collisions.
In the physics tab of the properties panel, change the Source from "Deform" to "Final".
Only "Final" takes the modifiers in to consideration, hence your trouble.

The other setting you need to change is the rigid body collision Shape, set it to "Mesh".
rigid body settings

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.