0
$\begingroup$

I try to make looping animation of falling particles.

I created particle system on a plane with the following settings:

Physics:

  • Type: Newtonia
  • Brownian: 9.03
  • Drag: 0.318
  • Damp: 0.103

Force fields:

  • Type: Turbulence
  • Strength: 15.0

First particle system starts at frame -50 and ends at frame 50, second - at frame 50 and ends at 150.

When I have a single particle system particles fall down as expected. If I add a duplicate of the first particle system - and even if I add a completely new particle system and type its settings by hand - particles start misbehaving at frame 51 onwards - they start flying in random directions instead of falling down - i.e. animation changes to a some sort of explosion instead of falling down.

Perhaps force field settings need to be tweaked somehow to prevent this effect and make particle systems to "blend" seamlessly?

$\endgroup$
2
  • $\begingroup$ Possible duplicated blender.stackexchange.com/questions/198835/… $\endgroup$
    – Emir
    Dec 20, 2023 at 19:09
  • $\begingroup$ It doesn't seem so - the effect still exists when the first particle system gets disabled. $\endgroup$
    – J. A.
    Dec 20, 2023 at 22:18

1 Answer 1

2
$\begingroup$

In the Force Field settings you are Turbulence with each particle as effector and strength of 15.

That is too much to keep the system stable if each particle acts as an effector.

Instead chose a few particles among the whole set to act as effectors. You can set the Effector Amount to 10. Also you can enable Self Effect to affect the particles of their own particle system. Do the same for both particle systems.

Also sometimes the Cache is buggy and you have to reset it by changing a value for example the Seed. To run the simulation correctly I've found that moving the playhead to the initial frame in this case -50 helps. To do this Allow Negative Frames in your Preferences so you can move the playhead on a negative frame (note your animation still starts at 0)

enter image description here

Here is a blend file that will work with the described settings above

$\endgroup$
2
  • $\begingroup$ Thank you very much! I found another possible solution which is to empty effector collection. Yours indeed is cleaner. $\endgroup$
    – J. A.
    Dec 20, 2023 at 22:19
  • 1
    $\begingroup$ You're welcome. $\endgroup$ Dec 21, 2023 at 13:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .