0
$\begingroup$

I'm working on a scene with a smoke simulation.

As far as I can tell, I have everything setup correctly. That's obviously not correct as I'm here with an issue but I just cannot figure out what the fix is.

This image below is a bake using 512 resoluition. Timesteps is set to 1,4. Adaptive domain is on and add resolution is set to 4. Noise is also on and Upres set to 5.

The emitter is also set to sampling substeps is set to 5.

Yet I'm still getting this blocky look in renders.

enter image description here

I've uploaded the blend file here.

https://drive.google.com/file/d/1CK-OWq-iiMg84QUSRUdpbJKWYmaiQOHL/view?usp=share_link

Is it really just a case of bumping the resolution even more? The bake times are already a bit too long.

I'm not that experienced with the Blender sims. This is also making the UI really laggy. How would the more experienced here tackle this situation?

Looking at all the objects involved their real-world dimensions seems fine. If I open a new blend and just create a smoke quick effect on the default cube the real world dimensions of the objects are comparable. I've applied scale transforms to the domain and emitter in case it was this, nothing seems to get around this blockiness.

TIA.

$\endgroup$

1 Answer 1

1
$\begingroup$

To me this looks like 2 different issues. First the resolution stepping you mentioned, this is best seen at the front of your emitter where we see the fuel being created, and I believe the best solution is just to up the res, as 512 isn't super detailed when its that close rendering at a 1920 image.

Although a few things that could be done to help speed up your sim since your emitter isn't travelling very fast you don't need so many substeps, your emitter substeps could be reduced to 1, and your domain timesteps could be reduced to 1 or 2. Combine a higher res and a little bit of motion blur and that stepping shouldn't be an issue.

The Second and bigger issue is what we are seeing in the yellow fire trail on the left of the image, it has very bad stepping but to me this appears to only be partly based on the resolution but mostly looks like the sim data values are being stretched.
We aren't seeing that same stepping in the green smoke or in the fire on screen right, so that's why I assume it's a stretched value in the yellow trail.
As if you are trying to pull out more detail than what exists in the sim, I assume this is the thin fading off tail end of the fire but you are adjusting it in the material to try and boost the values so its getting bright and dense just before it dies off. I have previously seen similar when trying to stretch out a small section of data to cover a wider range (ie adjusting .05 of the data range to cover .8 of the space, hopefully that makes sense). In other words, I don't know if you are using Curves, Ramps, Remaps or what to bring up that data but it looks like its adjusting it too much, and trying to display data that the sim doesn't have enough info to show so it can't transition smoothly.
If that is the case you can fix this by lowering your fire reaction speed so the fire lasts longer and thus you would have a wider range of data to manipulate and adjust to achieve the same effect.

Additionally in your render properties, under light paths> max bounces, makes sure you up the volume bounces to 1, this will help give more detail in your smoke lighting.

Hopefully that was of some help.

$\endgroup$
9
  • $\begingroup$ What a mine of info. Thanks for taking the time to take a look. It's interesting to hear that 512 isn't considered high detail here, given the composition. But like you said, it's a confluence of issues. I'm going to wokr through the points you've raised and report back. Many thanks. $\endgroup$
    – Jammer
    May 15, 2023 at 20:33
  • 1
    $\begingroup$ Now that I'm thinking about it the material was from an online tutorial for specfically pulling more detail out ... interesting that it's potentially the source of these artifacts. $\endgroup$
    – Jammer
    May 15, 2023 at 21:04
  • 1
    $\begingroup$ I'm not sure I haven't done any 4k projects myself. For res there isn't any rule of thumb I'm aware of, its usually just trial and error for how much you can get away with and what looks good. Also if you can use motion blur to help blend the sim that helps a lot and allows you get away with lower settings, but if its a thing where you need it looking crisp, you'd wanna up the res a fair bit. work at 512 for set up but I'd probably aim for around 1280 for final (hopefully less, but maybe more), see if that worked, don't be afraid of leaving your machine simming for 12-16 hours overnight. $\endgroup$
    – McBrett
    May 16, 2023 at 15:21
  • 1
    $\begingroup$ Also my original comment about the 512 not being enough, was based off the test file set up, because the camera isn't moving and I noticed you had the domain hanging over about 2+ meters on camera right (you want the domain overhanging screen left to let the sim start before it enters frame, but screen right isn't needed). If you tighten the domain box to the frame it will help shrink your voxel size and basically boost your res, as right now you are likely seeing less then 400 of those 512 voxels wide. I should have clarified that better $\endgroup$
    – McBrett
    May 16, 2023 at 15:27
  • 1
    $\begingroup$ All great points. The overhang on both sides is due to the animation I need to do. Also, with a lot of tweaking I've gotten fantastic 4k renders with only 300 divisions whilst I setup. Upping that for the final render is more than doable and will just look awesome. Thanks for your help. $\endgroup$
    – Jammer
    May 17, 2023 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .