2
$\begingroup$

I was working on a mesh the other day and I ran into a weird issue where the software just doesn't recognize the edge flow properly (not sure how else to describe it) - Basically I have a mesh made up of quads, and I think after I did some extrusions on it, it is not behaving in a strange manner. Below are some pics showing the problem.

This is the section causing or indicating the problem. I deleted the face to make it more obvious as to why it is the issue (as far as I can tell): Mesh with problem face removed

When this face is deleted, I am able to add edge loops around it no problem.: problem face removed, edge loops added

But when I fill that face in, the edge loops will not connect. Notice the edge loop stops one face sooner on the bottom this time compared to the last screenshot: problem face re-added, edge loops added

From another angle, you can see a symptom of the problem problem face shows a weird line in the mesh, symptomatic of the problem

After removing some of the surrounding geometry and rebuilding it manually, I got it to correct: enter image description here

But I was just confused about why it was happening to begin with. I tried selecting all the vertices and merging them by distance; I tried selecting vertices only the vertices of the problem face and merging by distance; I tried recalculating normals. I also noticed the knife tool isn't working as you would expect in this file, unless I am mistaken. I was modeling this in version 3.5. I've uploaded the blend file in case it helps to investigate.

Thanks for any help :)

$\endgroup$
5
  • $\begingroup$ It's difficult to see from those images exactly where on your model you are trying to add edge loops. If you show an image with more of the model visible and not in x-ray mode it might be clearer. Your blend file doesn't seem to show any problems assuming it's an uncorrected version but I may be trying to add a loop in a different place! $\endgroup$
    – John Eason
    Apr 11, 2023 at 13:07
  • 1
    $\begingroup$ @John Eason, maybe it will be more clear here: blend-exchange.com/b/WadoD7K5 I'm not sure what's happening as there is 2 visible edgeS if I hide the faces but there doesn't seem to be overlapping vertices... $\endgroup$
    – moonboots
    Apr 11, 2023 at 13:20
  • $\begingroup$ @moonboots Ah ok. It's only when you try to add a loop right round the edge of the back of the chair? No wonder I couldn't work it out from those images! :^) $\endgroup$
    – John Eason
    Apr 11, 2023 at 13:34
  • $\begingroup$ i tried your blend file. all is good. there are no problems. $\endgroup$ Apr 11, 2023 at 13:34
  • $\begingroup$ @HarryMcKenzie Ty adding a loop round the edge of the chair back! - It misses a bit although I can't see any problem with the geometry. $\endgroup$
    – John Eason
    Apr 11, 2023 at 13:36

1 Answer 1

1
$\begingroup$

To maximize your chances of getting help, make it as easy as possible for others to understand your problem. Here's what I did:

  • removed as much geometry as possible without removing the problem itself and save the file,
  • create a new file, A, X delete all objects,
  • File -> Append... And import the Cube object from the previous file,
  • File -> Save... And in the settings enable compression.

Now the file weighs only ~100 KB and it's clear what's the problem:

After enabling MeasureIt addon and vertex (red) + faces (green) indices visibility, I noticed some indices are missing: vertices 5, 9; face 2. Also, if in Edit Mode you switch to vertex selection mode 1 and select everything A, and open the Numbers Panel N, you will see the median location to be:

This is clearly some bug, perhaps caused by something like dividing the location by 0. In order to remove offending vertices, with everything still selected, press C for Brush select mode, and using $\color{#888}{█}\color{green}0\color{#888}{█}$ middle mouse button deselect all visible vertices, then press X to remove remaining vertices.

In order to more easily fix this in the original file with entire geometry, you can go to Edit Mode, then go to the Scripting tab, and run this Python script:

import bmesh
from bpy import context as C
from math import isnan

me = C.object.data
bm = bmesh.from_edit_mesh(me)

for v in bm.verts[:]:
    if isnan(v.co.magnitude):
        bm.verts.remove(v)
        
bmesh.update_edit_mesh(me)
$\endgroup$
1
  • $\begingroup$ Thanks for your help, this worked perfectly with no issues. $\endgroup$
    – Jeff
    Apr 15, 2023 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .