0
$\begingroup$

I can't get a shadow catcher to work. Here are the steps I followed:

  1. Create a new scene, and add an object and a plane.
  2. Set Render Properties > Render Engine to Cycles and turn on Render Properties > Film > Transparent.
  3. Turn on the plane's Object Properties > Visibility > Shadow Catcher.
  4. Render the scene.

I thought that this should be enough. The plane has certainly become invisible in the render, but the shadow of the object on the plane can't be seen either.

enter image description here

I'm using Blender 3.3.0 on Fedora Linux.

P.S. I've checked existing questions about shadow catchers and couldn't find anything that solved my problem. In particular "Shadowcatcher not working in 3.0" suggests deleting the light sources and adding new ones, but that didn't help.

$\endgroup$
4
  • $\begingroup$ Downloaded your file and it is working here out of he box, both with the existing lamp, or just with ambient light. How are you rendering, CPU, GPU? $\endgroup$ Nov 3, 2022 at 16:23
  • $\begingroup$ I'm using CPU rendering because my GPU driver is borked at the moment. Does that make a difference? $\endgroup$
    – user157201
    Nov 3, 2022 at 16:48
  • $\begingroup$ GPU vs CPU may some times unintentionally give different results due to different implementation or driver bugs $\endgroup$ Nov 3, 2022 at 17:15
  • $\begingroup$ Fair enough. At least now I know it's not a problem with the way I'm setting up my scene. $\endgroup$
    – user157201
    Nov 3, 2022 at 17:41

1 Answer 1

0
$\begingroup$

This problem occurs (for me) on the Blender 3.3.0 package installed via Fedora's package manager.

It does not occur on Blender tarballs directly downloaded from blender.org, whether 3.3.0 or 3.3.1.

It also does not occur on the Blender 3.3.1 package available via Flatpak. So for Fedora users, the easiest way to fix this problem and still get automatic software updates is to install using Flatpak: go to Software, search for Blender, change the dropdown at top right from "Fedora Linux (RPM)" to "Flathub (Flatpak)", and then install.

$\endgroup$
1
  • $\begingroup$ I got the Nvidia driver working again and now the Flatpak package no longer runs: it crashes with an "X11 glXChooseVisual() failed" error in the command line. Luckily the tarball downloaded directly from blender.org still has no problems. $\endgroup$
    – user157201
    Nov 5, 2022 at 19:48

You must log in to answer this question.