0
$\begingroup$

I am trying to distribute a sesame seed mesh on a bun. I can get my instance to show, and my original mesh I'm distributing the instance on shows in the viewport after the join geometry node is added. However, I can't get "the bun" to appear in the render (cycles or evee).Only the instance renders.

Where am I going wrong here? I went into the object data just to triple check and it looks like render and viewport is enabled. All transforms are applied just incase. https://pasteall.org/blend/c2688e6493a24d288509bece57ef9220

heres the file^^ enter image description here

$\endgroup$
2
  • $\begingroup$ maybe you didn't click the camera icon in outliner? if this doesn't help, provide blend file, so we can check it out. The reason is not in the geometry nodes tree $\endgroup$
    – Chris
    Jan 23, 2022 at 3:40
  • $\begingroup$ Camera seems good... pasteall.org/blend/c2688e6493a24d288509bece57ef9220 Heres the file! $\endgroup$
    – Chris V
    Jan 23, 2022 at 4:48

1 Answer 1

1
$\begingroup$

add a realize instances after join geometry

enter image description here

$\endgroup$
4
  • $\begingroup$ This is very strange. Have any idea why the unrealized mesh isn't showing and why realizing it fixes it? $\endgroup$
    – Benus
    Jan 23, 2022 at 5:08
  • $\begingroup$ @Benus: You are right and i have no idea why it is that way - but it works ;) ...might be a bug $\endgroup$
    – Chris
    Jan 23, 2022 at 5:11
  • $\begingroup$ Thank you other Chris! $\endgroup$
    – Chris V
    Jan 23, 2022 at 15:15
  • $\begingroup$ You are welcome. Please click on the checkmark left to my answer, if this helped you. Thanks! $\endgroup$
    – Chris
    Jan 23, 2022 at 15:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .