I'm fairly new to blender,I started following this tutorial but the results are a bit far from what I want.

I want to manage to get the crystal material to be transparent, so when the light comes through, it reflects on the ground with the color of the crystal, right now, a hard black shadow is cast.

I cranked up the transmission to 1 and made sure the transparent shadow was enabled but I can't seem to make it glassy enough.

Any help would be appreciated as well as tips to improve the render.




2 Answers 2


For a crystal, You do not want to use a Principled BSDF. It has diffuse bounce which crystals do not.

Use a glass shader, and set the IOR to be just above 2. This should handle everything.

enter image description here

You're running into a limitation of the Principled trying to do everything, but it ending up terrible at it.


To have light travel through a Principled shader, the alpha needs to be less than 1. See https://docs.blender.org/manual/en/latest/render/shader_nodes/shader/principled.html

cristal with principled and alpha set 0.2

By setting the alpha on the Principled BSDF to 0.2, the result will match the image above.

Principled BSDF with recommended settings


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .