7
$\begingroup$

I'm trying to achieve a scratched surface effect using a bump map, however it turns out the surface details are not preserved at a distance:

The first picture shows the metal part at high resoltion, the second picture is a down-scaled version of it and the third picture shows the same part rendered at a distance.

This surprises me actually because Cycles obviously does supersampling for the primary rays, however it seems that it downsamples the textures on the fly or pre-calculates mipmaps instead of sampling the textures at full resolution.

$\endgroup$
  • $\begingroup$ Downscaling a render != moving the object farther away. There are differences in the way reflections will appear depending on light position etc. Without seeing a file or something to see exactly how you conducted the tests it's a bit hard to give more of an explanation than that.. $\endgroup$ – gandalf3 Jan 31 '15 at 0:43
  • $\begingroup$ The light in this scene is sufficiently far away to presume that there is no significant divergence. See my answer that changing the resolution does provide a workaround (and a difference, obviously). $\endgroup$ – Lenar Hoyt Jan 31 '15 at 3:48
5
$\begingroup$

It seems that Cycles does not allow to disable texture filtering as of now.

My solution is to render the scene at an insane resolution, but also to reduce the sample count by the same factor, and then downsample the result. It works very well this way.

If I haven't overlook something, I think, this is an urgently missing feature. It basically makes all textures look a little bit blurry if rendered directly at the intended resolution (because mipmapping is visually inferior to supersampling—especially for bump maps).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.