0
$\begingroup$

Fluid simulation problem: i have a fluid simulation that i want to animate. i do NOT want the flow to start on frame 1. I want it to start on frame 20, ending on frame 50.

I did the following:

  1. set a keyframe on frame 1 on the flow object (the one that creates the inflow) with the "Use Flow" checkbox off
  2. on frame 20 i added another keyframe with the "Use Flow" checkbox on
  3. on frame 50 i added another "Use Flow" checkbox on
  4. on frame 51 i added another "Use Flow" checkbox off

the unwanted result is that i see the domain cube as an object (as the fluid material) that covers the whole animation from frame 1 to frame 20. domain as an object from keyframe 1-20

$\endgroup$
3
  • $\begingroup$ I don't know your scene but have you tried to keyframe the visibility of the fluid domain? Hide it from frame 1 to 19, run simulation from 20 to 50, then hide it again because it will be shown as a cube again when the simulation has ended. Alternatively, you can do a cut in the animation after the simulation has ended. The fluid can be converted to a mesh to make it static (but this depends on how you render it). $\endgroup$
    – Blunder
    Jul 3 at 13:51
  • $\begingroup$ Yes. Doesn’t work. It doesn’t start the flow animation. $\endgroup$
    – Amir Lavi
    Jul 3 at 14:13
  • $\begingroup$ Do you bake the liquid simulation from frame 1 to 50? In my scene, it works. The liquid is baked from frame 1 to 190 but hidden in render and viewport ("camera" and "monitor" icons) until frame 110. The Use Flow checkbox is disabled. At frame 110 the domain becomes visible and Use Flow is enabled. The liquid flows. $\endgroup$
    – Blunder
    Jul 7 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.