3
$\begingroup$

I set keyframes on the min and max value of an "Attribute Randomize" node. Now I want to move those keyframes but I don't see them in either of the keyframe editing modes (Dop Sheet, Timeline, Graph Editor).

Is that intentional, a bug, or am a missing something?

This is in v2.93.1 on Windows 10.

$\endgroup$

3 Answers 3

4
$\begingroup$

Disable "Only show selected" on your graph editor and they will show up:

enter image description here

Unfortunately, everything else will show up too.

My recommendation for nearly any non-standard, per-object animated values, is to drive them from a bone rather than animate them directly. This gives you a single place to store all animated values for a single object on something discrete and easily selected, and it vastly simplifies the coordination of animated values when using NLA.

$\endgroup$
7
  • $\begingroup$ Thanks! But nope. The geometry node does not even show up in the list. I must be doing something wrong. A few days back I was putting noise on the values and saw the curves... $\endgroup$
    – alFrame
    Jun 30, 2021 at 14:36
  • $\begingroup$ How can I add a screenshot to a comment?!? $\endgroup$
    – alFrame
    Jun 30, 2021 at 14:42
  • $\begingroup$ @ alFrame You may have some other filters enabled in your graph editor that prevent them from showing up. Or, you may be editing a different action. I don't think I could give an exhaustive list of reasons why something doesn't show up, not without looking at a file. As for screenshots, just edit the question-- there's no reason not to include as much information as possible, including things already tried. $\endgroup$
    – Nathan
    Jun 30, 2021 at 14:46
  • $\begingroup$ Thanks Nathan! Your tip to look into filtering solved it. I had modifiers turned off. DOH... I checked the view menu, disabled "show selected only", selected the geometry node in the outliner, all that sitting and in a hand stand. Nothing helped. But now it's all good!! How do I select an answer? Answering my own question gave me negative points the other day. $\endgroup$
    – alFrame
    Jun 30, 2021 at 14:58
  • $\begingroup$ @alFrame I don't remember, it's been a long time since I asked any questions :) But I wouldn't stress it (or points) too much if I were in your shoes. The ultimate issue here is you had some filters enabled that you didn't mention in the question, so it's not a great candidate for a top Google hit for anyone anyways. $\endgroup$
    – Nathan
    Jun 30, 2021 at 15:36
1
$\begingroup$

at least i have a workaround for you:

Just plug the min/max to your "Group input"-node and then you can keyframe then on the modifier panel (in the picture on the right side where the yellow color is) and this you can see and modify in the graph editor.

enter image description here

$\endgroup$
2
  • $\begingroup$ Thanks for that tip! I found this approach on the interwebs as well. But rigging x,y and z min/max of 3 animated nodes just to be able to manipulate the keyframes is reeeeeal tedious. $\endgroup$
    – alFrame
    Jun 30, 2021 at 14:24
  • $\begingroup$ No hard feelings $\endgroup$
    – alFrame
    Jul 2, 2021 at 20:12
0
$\begingroup$

This is way late, but I found that once you do uncheck the box. If you open another window to the shader/geometry nodes in which you have the key frames, and select the box with the key frames programmed, it will then show up on the door sheet/timeline, but you need to have it selected, otherwise it will show only basic key frames such as rotation and transforms.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .