0
$\begingroup$

I have done a locrot on a sphere and also has pressed i on a value in the node editor. I have tested it in a blank location and the keyframes for my fac value definitely places and animates properly but I cannot select it. It seems to unify as part of the sphere animation. Is there a way to seperate the keyframes or at least select them individually, i.e. where is the "fac" keyframe for the value I set?

enter image description here

As you can see, the mix shader has got a frame assigned to it and acts accordingly when sliding the timeline, and in the final render but I see only 1 key.

To demonstrate, enter image description here

And after putting the frame in it registers on my fac value and places 2 keyframes in the dope sheet and clouds section. I was hoping to isolate these frames at frame 0 enter image description here Note that these 2 frames aren't in the file I upload I just added it for reference purpose. They are set however for frame 0 but I cannot select them as they seem hidden.

$\endgroup$
  • $\begingroup$ It should be in the Dopesheet like any other keyframe, please share your file so that we can test: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Jan 13 at 9:19
  • $\begingroup$ sorry was half way through doing that earlier and my mouse broke. I will upload it in the morning with images once I have a working mouse. I thought that too but seems to be tied in with the cloud key. I will upload with images and indicators to illustrate the issue tomorrow. Thanks for getting back to me. $\endgroup$ – Mark Mathews Jan 13 at 10:34
  • $\begingroup$ It has been updater adn the file added for looking at if needed. I tried to be as detailed as possibly without going overboard. $\endgroup$ – Mark Mathews Jan 14 at 8:54
  • $\begingroup$ can you please reformulate your problem because I don't see any problem with your file, you have created some keyframes for your Mix Shader, and if you go in the Dopesheet you can move these keyframes as you want. In the Dopesheet, if you click on the arrow icon button (on the left of the phantom button, you will display only the keyframes related to the object selected on the 3D View, if I enable this option and select the Clouds object I see all the keyframes related to Clouds, and on the left you can see that you can clearly access to its material (Shader Nodetree) $\endgroup$ – moonboots Jan 14 at 12:02
  • $\begingroup$ Thank you for that. I am a Max to Blender convert. They taught me 3ds max so I was used to each item being seperated and was unaware of the tree embedded within the clouds item. This has solved it for me thanks. $\endgroup$ – Mark Mathews Jan 14 at 12:37
0
$\begingroup$

You have created some keyframes for your Mix Shader, and if you go in the Dopesheet you can move these keyframes as you want. In the Dopesheet, if you click on the arrow icon button (on the left of the phantom button, you will display only the keyframes related to the object selected on the 3D View, if I enable this option and select the Clouds object I see all the keyframes related to Clouds, and on the left you can see that you can clearly access to its material (Shader Nodetree).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.