0
$\begingroup$

I have had this problem for a long time, most often occuring when extruding something ( faces, armature, vertices ), this time I menaged to capture it in submitted blend file.

The thing is, after cancelling extrusion with right click I experience severe slowdown of CPU that persists for a long time and causes crashes. In submitted example it happened when extruding single vertex with skin modifier. I noticed that every incomplete extrusion causes this vertex to duplicate in exponential way at its coordinate - merging vertices by distance later results in removing from 17 to 170 vertices ! To reproduce this simply extrude vertex from my file, right click to cancel, and clean up mesh merging by distance. It happens despite of auto-merge vertices turned on.

What can be the cause of it ? I suspect there is something wrong with my project setup ? I never encountered similar problem in the internet, yet it happens to me almost every day

Blend file in the comment below. Using 2.92

$\endgroup$
8
  • 2
    $\begingroup$ Canceling the extrusion doesn't delete the new vertices that are created - it only cancels the movement. Some people use this intentionally to cancel the movement so that the pixels stay in place and then scale them down to make an inset (why they don't simply use 'I' to inset a face I never understood). $\endgroup$ Jun 30 '21 at 9:04
  • $\begingroup$ I read it somewhere, but how come single extrusion cancel of single vertex results in 10-50 new vertices ? Every cancel poses a threat to crash Blender this way. And I was hoping auto-merge vertices would deal with this $\endgroup$ Jun 30 '21 at 9:08
  • $\begingroup$ By the way, you can edit your question to add the blend file to it, no need to put it in an extra comment. $\endgroup$ Jun 30 '21 at 9:08
  • $\begingroup$ I guess, if you're selecting vertices (maybe in X-ray mode,) with some area-selection method, then the number of vertices would grow exponentially., since each extrusion is of the entire last batch. @Gordon.. it's not only insets. there are many other moves that start with a dropped extrude or inset... (at least, for me :) ) $\endgroup$ Jun 30 '21 at 9:42
3
$\begingroup$

I downloaded your file and checked it. First of all, Auto Merge isn't enabled there so it cannot work. The other thing is, your object already consists of 9 vertices, 12 edges and 6 faces all lying in the same spot. Looks like you took a cube, scaled it to 0 without Auto Merge and extruded one vertex and right-clicked it.

I don't know if you select them all before extruding them so that you get so many vertices, I would clean it up beforehand by selecting all with A, then hit M to Merge > By Distance. Now there's only one vertex left. If you extrude this with E and right-click to abort, there are only two vertices now, the original and the extruded one - not multiple new ones.

Auto Merge doesn't delete this new vertex not although you abort the extrusion but because you do it. Auto Merge "decides" after some kind of editing, translating etc. if two vertices are within the Threshold distance. If so, they get merged.

This means, let's say two vertices are 0.05 m away from each other. If you now enable Auto Merge even with a Threshold of 0.1 m, the vertices will not be merged - because none of them is moved or scaled or rotated etc. at this moment.

To merge them, you can hit G and move one or both. If they stay closer than the Threshold of 0.1, confirming the movement with left-click or Return will merge them together. However if you abort the movement, Auto Merge treats them as if nothing has happened and doesn't look if there is something to merge.

The same happens when you extrude a vertex. If you move it just a little within the Threshold distance and confirm the extrusion, the vertices will be merged at their center. But since aborting an extrusion doesn't delete the new vertices and only cancels the movement, Auto Merge treats those vertices as if they were always there so close together and didn't move - so there's no merging.

$\endgroup$
2
  • $\begingroup$ I see, so thats because of the way I collapsed the cube in setup. Thank You vaery much, I understand how blender handles merging now, I will be able to not crash my CPU after few extrudes now :) $\endgroup$ Jun 30 '21 at 9:58
  • $\begingroup$ @KrzysztofSwierzy I think it will be the skinning that's gulping down your clock-cycles, trying to work out how to skin the junctions at 512-branch nodes. $\endgroup$ Jun 30 '21 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.