1
$\begingroup$

I have strange shading after importing an obj file:

enter image description here

enter image description here

When I zoom in, the face seem perfectly flat. I checked normals, they are ok. I also tried the "clear sharp" function, nothing changed. Also tried "remove by distance" but no vertecies were deleted.

I searched a bit around here for an answer that already exists, but shading issues are dime-a-dozen with very specific issues, non of them helped me.

Does anyone know what's the problem here and how to fix? Thanks in advance!

$\endgroup$
4
  • $\begingroup$ You cleared custom normals? $\endgroup$
    – scurest
    Mar 27, 2021 at 13:48
  • $\begingroup$ @scurest sorry, I don't know what that is about... can you point me towards a resource where I can learn about that? $\endgroup$
    – Raku
    Mar 27, 2021 at 17:26
  • 1
    $\begingroup$ This. $\endgroup$
    – scurest
    Mar 27, 2021 at 17:32
  • $\begingroup$ @scurest Beautiful! That did it. Very simple. $\endgroup$
    – Raku
    Mar 27, 2021 at 18:42

2 Answers 2

3
$\begingroup$

I fixed this by clearing custom normals.

$\endgroup$
0
$\begingroup$

I had something similar. In object mode under the object menu I changed the setting from "shade smooth" to "shade flat."

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .