I was trying to create a self-luminate ball with Cycles as renderer, however when I linked an Emission node to the Surface, the ball just showed nothing. I added a plane beside it, there is light on the plane, but the ball was still there like dead. I have put the file as a link. Can someone help me with this? Thank you very much..blender file

enter image description here

  • $\begingroup$ Read: blender.stackexchange.com/questions/175397/… $\endgroup$
    – susu
    Jan 25, 2021 at 9:23
  • $\begingroup$ Thank you susu I tried the volume scatter and it seems working. Im sorry I clicked the red flag by accident and I didn't mean it. thank you very much! $\endgroup$
    – sk8erchen
    Jan 25, 2021 at 9:45
  • $\begingroup$ you could also do this effect in the Compositor $\endgroup$
    – moonboots
    Jan 25, 2021 at 10:06

1 Answer 1


Haze will not appear by magic, you have to put it there. It is not a quality of the object, but one of the environment where the lights are.

Even though we live in very polluted world, where there are so many suspended particles floating in the air, in the world of blender the air is totally clean and transparent.

Light in the air is only visible if you make it travel in an environment that simulates small particles floating. Such simulation is done by creating an environment with volume scattering.

In the world settings you can add volume scatter as volume material for the whole scene, or you have to create a large mesh that uses volume scatter as volume.

For more details read:

Atmospheric lighting in cycles


How do volume shaders interact with light?


Not the answer you're looking for? Browse other questions tagged .