1
$\begingroup$

I am using the 2.1.8 Animation Nodes + Extra Nodes build from https://blender.community/c/graphicall/ in Blender 2.90.1. I am using this build specifically because the Materials nodes are different and seem less functional in AN 2.2 (in particular, the Cycles attribute output node does not accept a Material input in 2.2, but in 2.1.8, the Material Attribute Output node does).

I am instancing materials and applying them to different metaball systems, which are all instanced from a single metaball. The metaballs all get the same name by default, with instance numbers: if the parent object is named "MBall" then the instances are "MBall.001", "MBall.002", etc. Because the objects are metaballs, this puts them into the same meta system, and the whole system uses the material of the parent ball. Therefore I must rename the instanced objects to assign individual materials.

This is how I did that: enter image description here

It works but the project becomes very unstable and usually crashes on render. In the crash report file, the stack trace seems to indicate an issue (EXCEPTION_ACCESS_VIOLATION) during renaming from within the node graph:

Stack trace:
blender.exe         :0x00007FF6A7795820  blender::deg::`anonymous namespace'::deg_graph_node_tag_zero
blender.exe         :0x00007FF6A7795E30  blender::deg::graph_id_tag_update
blender.exe         :0x00007FF6A7796AF0  DEG_id_tag_update
blender.exe         :0x00007FF6A76E9780  ED_node_tag_update_id
blender.exe         :0x00007FF6A76E98A0  ED_node_tag_update_nodetree
blender.exe         :0x00007FF6A725AD00  rna_NodeSocketStandard_value_update
blender.exe         :0x00007FF6A7240C00  rna_property_update
blender.exe         :0x00007FF6A723DB10  RNA_property_update
blender.exe         :0x00007FF6A7337D40  pyrna_py_to_prop
blender.exe         :0x00007FF6A732F4E0  pyrna_struct_setattro
python37.dll        :0x00007FFB0D1B6D90  PyObject_SetAttr
...

Is this a bug or is there a different/better way to rename my objects?

$\endgroup$
3
  • $\begingroup$ Hello, there's no input in the object field of the Object Attribute Output node $\endgroup$ – Gorgious Jan 6 at 10:58
  • $\begingroup$ Oh, that's true -- I was disconnecting it for some testing. After playing with it some more I think that the problem is not caused by renaming. I deleted that entire section of the graph and I still get frequent crashes when trying to render, pointing back to blender::deg::graph_id_tag_update. $\endgroup$ – slerfsterdn Jan 6 at 12:03
  • $\begingroup$ Looks like a problem occured in the build, you should try to rebuild it from scratch or from a previous stable version ? $\endgroup$ – Gorgious Jan 6 at 12:39
0
$\begingroup$

This question is now moot but I'm not sure how to close it.

I believe that the problem I was experiencing here was due to using the AN+EN build for 2.83 LTS with Blender 2.90.1 instead.

I resolved my Cycles material issue in 2.90.1 with a simple script:

materialIn.node_tree.nodes["Principled BSDF"].inputs[17].default_value = newColor
materialOut = materialIn

and now I'm just using the latest AN and EN in 2.90.1, without a lot of crashes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.