0
$\begingroup$

I'm making a animation, combining grease pencil objects with 3D objects. This looks very cool. But there's one problem. Grease Pencil and the particles system don't play nice in Eevee.

This is an example: Grease Pencil object between two 3D objects

A grease pencil object, a white blob, is placed between two 3D cubes. Then a 3D stylized conifer (a type of bush) is added.

Grease Pencil object behind a 3D bush

So far, so good. The white blob is covered by the conifer. But then I add a particle system to the 3D conifer. And that's when it falls apart. Rendered in Eevee, the white blob (= Grease Pencil object) hides behind the 3D conifer, but appears above the generated leaves (particle system).

Grease Pencil covers the particle leaves of the 3D bush

That this set-up can work, is demonstrated when I render it in Cycles:

Grease Pencil and particles in Cycles

Am I missing something here? Have I forgot to check a box or is this just a quirk of Eevee.

I use Blender 2.82 (on a Mac)

Hope somebody can shed some light on this matter.

$\endgroup$
0
$\begingroup$

I found the possible culprit of the problem and the solution:

In the material properties-tab of the material (in this case the leaves) I found the solution.

material properties tab

Because I used a png-file of the leaves with transparency I opted for the Alpha Blend. But somehow the 'backface Culling' was ticked. This was NOT a good idea. When unchecking the box it worked.

enter image description here

Although I got better results with the hashed option in the Blend mode.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.