2
$\begingroup$

I'm testing out the basic functions of the Grease Pencil by drawing some sketchy lines on simple objects. In the viewport, when in Render mode, the lines look as expected. When I render them in EEVEE (F12), some of them appear broken. I've quite literally gone through all the different render settings in EEVEE (including new settings like anti-aliasing for GP), and on the Grease Pencil object itself, and have not found anything to make these appear correctly when rendering.

I've attached a screenshot of the difference between the viewport & a final render. This is the same in 2.82a, 2.83 beta, 2.90 alpha & is driving me nuts (especially because it's the same render engine?!)..

pic

Any tips would be appreciated on how to get them to render correctly like they do in the viewport (without using Cycles - the lines appear correctly there).

EDIT: I've tried things like turning off bloom, AO, etc - basically tweaked everything in the EEVEE render settings with no luck.

Thanks!

$\endgroup$
0
$\begingroup$

After lots of rage & trial/error, I have a workaround for this:

  • Add an Offset modifier to the Grease Pencil object
  • Try changing the Location value by + or - 0.01 on whichever axis will move the GP object closer to the camera & away from the 3D object.

I'm assuming this is a bug in Blender, causing the GP object to be considered closer to the 3D object it's near. For animation, I've keyframed the Location value of the Offset modifier & increase it when the camera zooms out & causes this issue. Then when I zoom back in (to where it renders correctly), I keyframe the Location value back to 0.

Hope this helps somebody.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.