5
$\begingroup$

so I'm working on a little bathroom scene and wanted to make a clay render. I started looking for the material override which I kinda knew where it was and on the way I switched my render engine accidently to workbench instead of cycles. Switched to cycles all my seetings on the render tab are missing except color management and free style. Hows that? I restarted blender multiple times and tried some other stuff but nothing changed a thing, and I'd rather avoid a new installation

$\endgroup$
2
  • $\begingroup$ Try opening a new instance of Blender and press Ctrl+O. In the file viewer, select your project and click on the gear wheel in the upper right corner to open the settings. Uncheck "Load UI" and open the project. If this brings back the settings, it means something's wrong with the UI setup in the file. If you don't mind losing that, you can re-save and it should be fine, all other project data will stay the same. $\endgroup$ Apr 9, 2020 at 20:55
  • $\begingroup$ thank god for dudes that sit there and click every button in Blender to see what they do, without you guys we would be lost, thanks for this answer $\endgroup$
    – Ceph
    Apr 7, 2023 at 6:28

2 Answers 2

12
$\begingroup$

This typically happens, when you check Filter Add-ons in the Tool tab.

Filter Addons allows disabling certain addons under certain workspaces. Since Cycles is integrated into Blender through an addon that means it gets disabled as well.

Otherwise check to see if the addon is globally enabled in Preferences > Addons.

enter image description here

$\endgroup$
5
  • 4
    $\begingroup$ Cycles is also an add-on, which is why the panels are hidden when filtering the add-ons. $\endgroup$
    – Robert Gützkow
    Apr 9, 2020 at 20:54
  • $\begingroup$ Good to know, thanks :). $\endgroup$ Apr 9, 2020 at 20:58
  • $\begingroup$ "Cycles is also an add-on" mind-blown. Nice solve! $\endgroup$ Apr 9, 2020 at 21:21
  • $\begingroup$ Ohhh thanks, ist quiet possible that I accidently checked this box $\endgroup$
    – Dangerouss
    Apr 10, 2020 at 8:03
  • 1
    $\begingroup$ Thanks to @Duarte for improving this answer :) $\endgroup$ Jun 16, 2021 at 15:01
0
$\begingroup$

Try a new file, then in the file open dialog you will see a gear icon in the upper right. Click it, then untick "Load UI". See if that brings things back for you. You could also try restarting your computer. Otherwise, you may have a corrupt .blend file? In that case, you might be able to File>Append your assets from the old file into a new one.

$\endgroup$
1
  • $\begingroup$ Thanks for the answer, but I doubt that the blend file is corrupted because it happened so suddenly but I'll try it $\endgroup$
    – Dangerouss
    Apr 10, 2020 at 8:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .