0
$\begingroup$

enter image description here

I am currently trying to make a jellyfish animation and I want to make it so that the 4 big tentacles slowly flop around, as if they're in water. In order to accomplish this, I'm attempting to create a vertex group for the tentacles and apply a soft body simulator to it. The goal is to make it so that the tentacles flop around like the moon jellys in this video , while, at the same time, the main body keeps its consistency. Unfortunately, I'm having problems with the soft body simulator. Whenever I apply it, the whole thing distorts like this:

enter image description here

I've spent the whole day trying to figure this out, and haven't had any luck whatsoever. I read another forum somewhere that said to apply a rigid body with the soft body, but I haven't had any luck with that either.

Does anyone know how to apply the soft body simulator on a certain part of your mesh???

Here's a copy of my project.

$\endgroup$
11
  • 1
    $\begingroup$ The Laplacian modifier would do this. Don't let anyone tell you it's no good when the model itself is also animated. (Blend file available if needed) Note, the tentacle flowing movements would need to be animated. A lattice modifier might also do the job. $\endgroup$ – Edgel3D Apr 8 '20 at 2:24
  • 1
    $\begingroup$ Did you try to assign the vertices of the non moving part to a Pin Group? $\endgroup$ – Bruno Apr 8 '20 at 9:54
  • 1
    $\begingroup$ I have a few actually. I've also been toying with your particular question and (sort of) done that in a hurry yesterday. The demo gif's are too large, so I'll place those and some others with it into an mp4 video and put them up on Dropbox. You can view/download that first, see if anything interests you. Remember though, these are all animated tentacles/tubes. None are automatic like @Bruno 's Stay tuned... $\endgroup$ – Edgel3D Apr 9 '20 at 3:30
  • 1
    $\begingroup$ @SMH , The 'collection' video, any of which might do your job is up on Dropbox. The link - dropbox.com/s/30aqyg94rm9xttr/ALL_Tentacles.mp4?dl=0 . $\endgroup$ – Edgel3D Apr 9 '20 at 11:40
  • 1
    $\begingroup$ No problems mate! Glad you got there. $\endgroup$ – Edgel3D Apr 23 '20 at 13:56
2
$\begingroup$

enter image description here

If you want certain vertices of your mesh (here: all vertices except the ones of the tentacles) to completely "ignore" the softbody-sim and animate like they originally did, three things are required:

  1. The vertices you don't want to move need to be assigned with a value of 1 to your goal vertex group
  2. The "Default" value in the strength settings of the goal property needs to be one as well
  3. The max Strength value needs to also be 1

enter image description here

This basically tells the softbody-sim that those vertices want to be completely animated with their goal, which actually is just their default animation.

So basically instead of this: enter image description here make your vertex-group look like this: enter image description here

Keep in mind however that even though those value-1-vertices will not be affected by the softbody-sim, they still will be taken into account while baking and thus slow down that bake. Don't ask me why.

$\endgroup$
2
  • $\begingroup$ thanks your input! I will probably be doing a project similar to this one and I may try you method. Thanks! $\endgroup$ – SMH Apr 23 '20 at 0:20
  • 1
    $\begingroup$ No problem my man $\endgroup$ – Cardboy0 Apr 23 '20 at 11:59
3
$\begingroup$

Cloth simulation Pin Group should do the trick. Just assign the non moving vertices to a specific group and use it in the Shape/Pin Group field of the cloth simulation settings panel.

enter image description here

$\endgroup$
2
  • $\begingroup$ How do you make it so that it's not as wrinkly and flaccid? When I used the cloth simulation, it acted too much like cloth. Do you know if there's a way to make it drift like something fleshy or jelly in s current? $\endgroup$ – SMH Apr 8 '20 at 10:37
  • $\begingroup$ just reduced the tension, compression etc... as you can see in the GIF screenshot. With default values, it is too stiff indeed $\endgroup$ – Bruno Apr 8 '20 at 11:22
0
$\begingroup$

Sorry I forgot to actually post my answer. So what worked for me were these settings with the soft body simulator.

enter image description here

enter image description here

For the control point and the vertex group under goal, I used the "mb2" vertex group.

enter image description here

And for the springs under the edges section, I used the "big tentical" vertex group.

enter image description here

That seemed to do the trick.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.