I'm trying to experiment with mixing 2d and 3d. I have my scene all set up:

enter image description here

I want the camera to move, and I want the characters in the scene to be 2D images. I want to add the characters in as a PNG with an alpha channel in the scene itself and not composited on top, so I don't have to worry about making the image move perfectly with the camera, if that makes sense.

When I add in my character as an image-as-a-plane, parts of her are clipping into the other objects in the scene. Like this (you can see her arm clipping into the couch):

enter image description here

I don't want to draw the characters in with Grease Pencil because of the lack of brush variety. And I don't want to composite the characters in after rendering because I want the camera to be moving, and compositing afterward would be harder to keep everything in perspective.

I want to be able to put the PNG in the scene, but have it always on top and never clipping into the other objects of the scene. I can do it with reference images, but they don't show up in the render. I'd really appreciate the help.


  • 1
    $\begingroup$ Hello :). Well, you could re-render only the 2D character in a separate view layer, and then composite it on top. That would take care of the clipping. $\endgroup$ Feb 28, 2020 at 19:47
  • $\begingroup$ Vers 2.77 you can use the X-ray option to place images on planes as always to front. Hopefully this still works in 2.8x. It might be worth a try. Details - Add a plane, give it a Material slot and slide it's Specular slider to zero. Also - Tick the Transparency box, open that tab and set both the Opacity and Specular sliders to zero. Give the plane a Texture slot and down in the Influence tab, tick the alpha box. In the plane's Properties panel (the cube icon) open the Display tab and tick the Xray box $\endgroup$
    – Edgel3D
    Mar 2, 2020 at 1:20

1 Answer 1


Okay, I think I know something that will work (It seems so obvious now, but I'll leave the question up in case someone else has the same problem).

I'll put the PNG's in the scene and just deal with the clipping while I'm animating, then render them separately from the background, and composite them on top afterwards. I honestly kind of feel silly for not thinking of it sooner.

  • $\begingroup$ "and just deal with the clipping while I'm animating" -> Or check "In Front" (in Object properties / Viewport Display) $\endgroup$
    – thibsert
    Feb 28, 2020 at 18:15
  • $\begingroup$ Thanks for the response. I checked the box, but nothing changed. $\endgroup$
    – John Engel
    Feb 28, 2020 at 18:24
  • $\begingroup$ Sorry, I should have tested it before commenting. It works for Mesh objects, but not for Reference Images. $\endgroup$
    – thibsert
    Feb 28, 2020 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .