2
$\begingroup$

I'm new to blender and have this issue: I'm using the "Industry Compatible" keymap. In "Edit Mode" the keys 1, 2 and 3 swap between vertex, edge and face select - Great!

Now i want to customize it, so i'm adding a new preset "My keymap". As far as i understand this now is based on the "Industry Compatible" keympap and everything works accordingly. But if i close and start blender again, the 1, 2 and 3-key aren't working anymore. I need to go back to the preferences, set the "Industry Compatible" keymap and then set back to "My keymap". Then the 1, 2 and 3-key work again as expected.

This is reproduceable on the last Blender 2.8 version on several different machines. Am i doing something wrong? Is this a bug?

$\endgroup$

closed as off-topic by David Aug 7 at 13:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1
$\begingroup$

Update: In Blender 2.81 you will be able to use 1, 2 and 3 for switching vertex, edge and face select even when your keymap is based on the Industry Compatible keymap. The operator is now decoupled from the specific keymap. It's using object.mode_set_with_submode as operator instead of ic_keymap.mesh_select_mode. This change was added with commit rB23d19c2b0dd3f47339ef07be39d47c41848be39b.


The reason this issue occurs is because the industrial keymap registers an operator called IC_KEYMAP_OT_mesh_select_mode which provides the functionality to switch between selection modes for vertices, edges and faces. However this registration happens only when the industrial keymap is loaded / selected in the preferences. A custom keymap based on the industrial keymap doesn't trigger this, resulting in a shortcut referencing an operator that doesn't exist. However if you open your preferences after restarting Blender and switch to the industrial keymap and then back to your custom keymap, it will have the operator registered because you have loaded the industrial keymap before.

$\endgroup$
  • $\begingroup$ Alright, i guess it will take a while until this will be changed, so i made an external script with this operator and it seems to work for me for the time being. Thanks for that hint! Basically i just copied the python code from the keyboard settings into a seperate file. Do you think i might run into troubles with that? $\endgroup$ – clawjelly Sep 2 at 13:56
  • $\begingroup$ @clawjelly should be fine. If there are any errors happening in a script or add-on you will see the exception in the console. If it's a function workaround atm, it will continue to work until the change the API or there is a name collision in the registered classes. $\endgroup$ – Robert Gützkow Sep 2 at 14:03
  • $\begingroup$ @clawjelly I've added an update on how to add the shortcuts in the upcoming Blender 2.81. $\endgroup$ – Robert Gützkow Sep 5 at 19:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.