0
$\begingroup$

This is really strange.

When I press Ctrl1 the view should switch to Back View, according to my preferences.

Keyboard configuration for Ctrl 1 shortcut

It's even listed correctly in the menu:

It doesn't do anything.

Ctrl3 for Left View is working, and Ctrl7 for Bottom View is also working.

I use Emulate Numpad as a standard always, even on machines where a numpad keyboard is available.

My OS is macOS Sierra. Blender version is 2.79.

The most bizarre thing is that it still doesn't work even after I Load Factory Settings (and re-enable Emulate Numpad). This makes me think it might not be my settings at all. (Possible bug?)

My Ctrl key and my 1 key are working just fine for all other uses, in Blender and in other apps.

It's really a hindrance when modeling. Any ideas?

Thanks.

$\endgroup$
5
  • $\begingroup$ Check if the operating system is using that same shortcut and re-map it or disable it... or get a proper keyboard with numpad or a usb numpad... $\endgroup$
    – user1853
    Feb 7, 2018 at 5:17
  • $\begingroup$ Thanks @cegaton. It certainly could be a system thing, although when I check in macOS System Preferences the only item I see using Ctrl 1 is a disabled shortcut for Mission Control. I do have a “proper” numpad keyboard on this machine, but I also use machines that don't, and I want consistency therefor I use Emulate Numpad as standard practice. I will keep searching for possible causes for macOS interfering, in case that is what is happening. $\endgroup$
    – Mentalist
    Feb 7, 2018 at 5:33
  • $\begingroup$ Have you tried it on other blender versions? Also, what happens when you remove your blender config files? $\endgroup$
    – Allosteric
    Feb 7, 2018 at 5:55
  • $\begingroup$ @Allosteric I have verified that on another machine I use (MacBook Pro) with the same Blender 2.79 and the same macOS Sierra 10.12.6 there is no problem whatsoever. I have also verified that the problem does not originate with the settings, because I tried removing the config files, and even swapped them with those from the working system. The iMac continues to have the problem regardless of the config folder status. $\endgroup$
    – Mentalist
    Feb 13, 2018 at 7:36
  • $\begingroup$ Try some show-what-key-you-are-pressing software within and outside blender. As for within, Screencast addon should be useful. As for outside, googling it gives you a dosen of choices. If you still have problems outsode blender, you should consult a macOS community. $\endgroup$
    – Allosteric
    Feb 13, 2018 at 23:22

2 Answers 2

0
$\begingroup$

The macOS Japanese text input implementation was interfering. By disabling it and using the Google IME instead I was able to regain normal functionality of my Ctrl key.

Anyone wanting to know more can read the question I posted on Ask Different that led to solving the mystery.

$\endgroup$
-1
$\begingroup$

Just using the blender in full screen mode enable ctrl+1 to be active.

$\endgroup$

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .