6
$\begingroup$

For a little bit now I've been working on a model and I've gotten to the stage where I want to apply an armature to them. So I did the whole "Automatic weights" part and was underway to touch up the weight paint. But no matter what I do in weight painting mode, nothing shows up. I can't see the weight on anything.

I've watched all of the tutorials on how to weight paint in 2.8 and they all say the same thing: Just Click Armature, Shift-click mesh, Go to weight paint mode. Simple. But when I get there, there's no colour for me to determine the weight.

enter image description here This is all I get. The arm on the right has been moved and the arm on the left is what it would look like relaxed.

According to the tutorials, this would be the part where I'd be able to do everything but there are no tools. I select to "Draw" option, try to paint and nothing happens. Which actually leads me to another question...

enter image description here Am I missing a part of my layout for this to work? In the tutorial videos I've watched they all have the same layout, an extra box below the header which shows the tools and options for them. I, on the other hand, don't have this nor do I know if there's an option for it.

Is this a bug? I really hope it isn't and that I'm just missing something because I really want to finish this model but I'm getting so frustrated over this little hitch.

$\endgroup$
1
  • $\begingroup$ This does not work for me either, no matter what I have thought of to do. Note: your menu issue, is in the render icon on the right when in weight paint mode. No need to adjust the menu's. $\endgroup$ – dave44 Oct 20 '19 at 19:16

10 Answers 10

0
$\begingroup$

You can activate the tool bar on the top by moving the cursor near the top of the viewport, right click and under header check the "show tool settings".

I however has maybe this same problem now in my 9 days old build of 2.8 that the weight paint isn't showing. It still works to weight paint, but no matter wich mode or overlay settings all i see is blue. I thought to remember i have painted weights earlier in this build, so i'm starting to wonder if this might be a bug? I believe this happened after i cleared parents and deleted the old vertex groups of my object, then parented with automatic weights to my modified armature.

Edit: I opened this in an earlier build and it weghts were visible, so i guess it's broken in that build. I'll check out the latest now. Edit again: I opened it in latest build and there it works fine, so that should be resolved.

$\endgroup$
2
  • $\begingroup$ It didn't work in my build from 2019-05-10 (found via Help -> Splash Screen) but it does work for the same project in my build from 2019-07-29. $\endgroup$ – petehallw Nov 2 '19 at 15:29
  • $\begingroup$ I also have a problem with weight paint. blender 2.81a. I see all blue, my tools are there but I just can't paint... $\endgroup$ – Merc Jan 17 '20 at 12:01
3
$\begingroup$

I had same problem on a flat plane, but after I subdivided the plane several times it worked.

$\endgroup$
3
  • $\begingroup$ This is a one line answer. It would help to lengthen it. $\endgroup$ – Nate_Sycro27 Dec 30 '19 at 14:09
  • $\begingroup$ Saved my day, exact same issue $\endgroup$ – Vinz Jan 7 '20 at 7:23
  • $\begingroup$ I had the same issue, this solved it for me. $\endgroup$ – Jane S Apr 20 '20 at 23:42
1
$\begingroup$

I had the same problem up to 2.81a, and finally found that you have to have the vertices SELECTED in Edit mode before going into weight paint. You can only paint on those vertices. This is nice because it gives you some control.

$\endgroup$
1
$\begingroup$

I had the same problem. However, I found another method that may help.

If you have your deformation bones layer visible you can 'Shift-Right Click' any of the deformation bones to bring up the "Weight Paint Sample Group" dialogue box which lists the bones in that area you can paint. From there you can select the DEF-Bone group you want and the weights will become visible for that bone. From there you can paint as you normally would.

I hope this helps!

$\endgroup$
1
$\begingroup$

I was having the same problem, I'm not sure if this will help you or others, but it fixed for me:

  1. Go to Edit Mode and select all vertices(A) before going to Weight Paint Mode (others have mentioned it already)

but also

  1. If your mesh has a Mirror Modifier on (like mine had), you won't be able to paint on the side that is mirrored (the one that displays no vertices on Edit Mode). You can either paint on one side (the "original") and use the mirror option in the Weight Paint Mode itself (though that produced strange behaviour for me) or simply go to Object Mode and apply the modifier, then go to Edit Mode, select all again and then go paint.

There are probably better ways to fix it, but since rigging and weight painting usually come last, it was not much of a problem to apply the mirror at this stage in my case. Make a copy of the mesh before anything to save you a backup.

Maybe this has nothing to do with your issue, but might help others, also perhaps other modifiers might be causing these conflicts.

$\endgroup$
0
$\begingroup$

I had the same issue in the tutorial I've been doing (it runs on a pre-2.8 version of Blender). I've found that by going into the tool settings (right-click Brush -> Header -> Show Tool Settings), you find an icon next to the Draw setting. If you click that, then select Add instead, it begins to paint the object the way you'd expect it too - albeit slower than the tutorial shows.

I'm a complete beginner so take my advice with a pinch of salt, but this seemed to work for me.

Hope this helps.

$\endgroup$
1
  • $\begingroup$ Just realized I had my Strength turned down so that's why it was weaker. Turn it up to anywhere between 0.6-0.8 and you should get the effect you're looking for. $\endgroup$ – Neil Thomson Aug 18 '19 at 14:03
0
$\begingroup$

I also had this problem. Go to \ VIEW -> check (TOOL SETTINGS) You can enable it in any mode. enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

My solution was linked to the one line answer by @Peter. Although I have to mention that you have to divide a plane in both directions:

Subdividing the plane in one axis still would not allow me to paint: enter image description here

Only after adding more vertices: enter image description here

enter image description here

The paint looks still a bit weird. Further subdivision will help. cheers

--------- Edit:

Oh no wait! I somehow also need to select the vertices, and then I can weight paint the vertices, but not the whole area.. I am still confused

$\endgroup$
0
$\begingroup$

MAYBE SOLUTION: I had the same problem. Was doing a bird and wanted to weight paint it where i wanted to distribute the feathers. First it worked, then I needed more resolution so I subdivided it several times. After that when trying to weight paint, nothing happened. After playing around I figured out, that I HAD TO SELECT ALL VERTICES WHILE IN WEIGHT PAINT MODE so it actually worked...

$\endgroup$
0
$\begingroup$

I had the same issue. The solution for me was to get back into Edit mode and chose the faces i needed to weight paint on, then switch back to weight paint and work smooth and easy only with selected faces (2nd picture darker blue color is my selected part of the mesh) Blender ur the best!

Edit Mode and the selected faces . Weight Paint and fully substracted weight on selected faces

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.