2
$\begingroup$

When rendering I get unexpected artifacts that somewhat look like artifacts caused by double meshes (Z-depth problem).

I am using Blender Internal. The scene/meshes are not complex at all. I experimented with render settings as well as light and world settings, but the artifacts are there whatever the settings. Even when rendered without shadows or any other "extras". The only setting that seems to change the appearance of the artifacts is the tile size.

I have double checked and am sure there are no double meshes in my geometry in object level or in sub object level. The normals are facing outward as they should. The meshes are not complex and clean.

I include rendered images here.

render output showing artifacts 1 render output showing artifacts 2

You'll find the .blend file here:

blend file here

I use:

  • Windows 7 64bit
  • Blender 2.70
  • ATI Radeon HD 5000 Series graphics Card with latest driver

I have searched Blender forums and learned that my graphics card was not the best choice for Blender... but as far as I know it should work well with the Internal renderer for CPU renderings.

So what causes the artifacts? How do I know if it's the graphics card causing it? Is there anything I can do about it or do I have to buy a card more suitable for Blender?

I noteiced two detailes that may be a hint...

  1. in perspective view the scene looks "clean", as it should, but when I change to camera view it appears messy.

  2. I am not confident about the unit settings. I was trying to work in centimeters, so I set "metric" and a scale of 0.01. But now the camera settings look unnormal: Focal length 0.28mm, sensor size 0.4mm...

$\endgroup$
  • 3
    $\begingroup$ Could you post picture or a blend file that shows the problem? It's hard to guess what's going wrong just by the description. $\endgroup$ – cegaton Jul 14 '14 at 5:33
  • $\begingroup$ I'll be able to post picture and blend file later this week. Have to get them from the machine at my workplace. $\endgroup$ – Booth Jul 14 '14 at 5:52
  • $\begingroup$ By "artifacts like double meshes", do you mean Z-Fighting? en.wikipedia.org/wiki/Z-fighting $\endgroup$ – CoDEmanX Jul 14 '14 at 12:49
  • $\begingroup$ That's right, the artifacts look like Z-depth problem to me. Please see updated description. $\endgroup$ – Booth Jul 15 '14 at 11:48
  • $\begingroup$ I use internal with very basic settings, like mentioned in the description. $\endgroup$ – Booth Jul 15 '14 at 12:09
5
$\begingroup$

It's due to your camera lens start clipping setting. It's set to 10µm (micro-meter, = 0.001 Blender unit).

For some reason Blender can't render surfaces correctly when the camera's clipping start distance is too low.

Try with some higher value, (e.g. 10cm = 10 Blender unit) and the problem is gone. Select the camera, go to camera tab in properties window, Lens panel:

enter image description here

$\endgroup$
  • $\begingroup$ Polosson, you are right - mystery solved! I am really very thankful for your help, very much appreciated. (I actually did notice the camera clipping plane being very low but never imagined changing it would solve all my problems). $\endgroup$ – Booth Jul 15 '14 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.