0
$\begingroup$

For some reason I'm not getting, the armature for the arms aren't staying in place when I move the root bone. I've added weights though, and they have vertex groups, so I'm not sure what's wrong. They just seem to 'fold' whenever I move the whole character.

enter image description here

$\endgroup$
  • $\begingroup$ could you please share your file? Why should the arm bones stay in place if you move the root? Maybe you meant something else? $\endgroup$ – moonboots Apr 8 at 13:06
  • $\begingroup$ Sorry, I have worded it wrong. Basically the armature doesn't move with the arms; they fall out. I've added a save to the original post. $\endgroup$ – DustyShinigami Apr 8 at 13:31
0
$\begingroup$

I think that you first need to make some armature corrections :

  • Rotate your IK controller in Edit mode to make it more easy to handle.
  • Deactivate its Deform option as it is not supposed to influence the mesh.
  • Unparent it, it is not supposed to be child of the hand, it is supposed to be parented with offset to the root bone.
  • Select the hand and make it the child of the controller.
  • You may also need to move the Pole Target, and also deactivate Deform.

Now when you select the mesh in Weight Paint mode, you can see that the chest bone influences the arms while it is not supposed to, so use the brush to correct that.

enter image description here

$\endgroup$
  • $\begingroup$ As far as I'm aware, I've followed your steps, but it's still doing the same thing. :-\ $\endgroup$ – DustyShinigami Apr 8 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.