2
$\begingroup$

My mesh looks torn with little holes when it's transparent but totally fine when opaque. Any idea what could be causing this and how to fix? EDIT: none of the holes are visible in edit mode, only if the object is transparent in object mode. Thanks!

Here I have some images. All are in object mode without any modifiers at all.

Transparency:

enter image description here

No transparency:

enter image description here

Again, no holes are visible at all in edit mode and are only visible when the object is transparent in object mode.

During a render with transparency on, it looks fine too! Only in the 3D viewport with transparency there is noticable tearing/blocky-ness.

$\endgroup$
1
  • 1
    $\begingroup$ Please use the tools on this site so that the images are displayed as part of your question and not as a link. How to upload an image to a post? $\endgroup$ – user1853 Jun 13 '18 at 18:39
1
$\begingroup$

This problematic behaviour can't be changed.

But since it is only a viewport problem, it won't affect the render. The backface and the frontfaces are both visible and don't get rendered properly. There are two temporary options.

  1. Don't show transparency in the viewport. Toggle off show transparency under Properties > Object. To preview the effect you'll have to use the render preview ⇧ ShiftZ.
    transparency properties object viewport
  2. Enable backface culling, that way the backfaces don't get involved in the viewport render. Transparent frontfaces are combined correctly.
    enter image description here
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.