As asked and answered in a previous question, Blender 2.6 handling of extended characters in font sets is bit awkward, aside from specific special characters

The workaround solution is copy pasting ALT### from other apps into the redo panel when editing text objects or copy pasting from other apps into text editor then using text to 3D Object.

Blender 2.4 had a character panel and 2.4 reference documentation mentions making fonts as well, where 2.6 reference omits these options.

So essentially, is there a script way to change/toggle the text editor itself to use fonts other than the default so that symbol fonts can be shown in the text editor in the process of modelling. This, as opposed to using several text objects with the font applied that sadly needs many copy/paste translation to get the full font character map set displayed.


1 Answer 1


You can enable International Fonts in CtrlAltU> User preferences > System to display special characters:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .