16
$\begingroup$

How can I add text in Arabic? I get rectangles instead of Arabic letters.

$\endgroup$
  • $\begingroup$ I found this directly on google. youtube.com/watch?v=kCoC89m3yGQ $\endgroup$ – Gunslinger Oct 25 '13 at 22:11
  • 1
    $\begingroup$ Related: blender.stackexchange.com/q/2687/599 $\endgroup$ – gandalf3 Oct 26 '13 at 0:29
  • $\begingroup$ A guess, but: - Ensure you have loaded a font supporting required glyphs. - Try using paste text from file function from the menu. $\endgroup$ – kivig Oct 26 '13 at 22:29
  • $\begingroup$ No, Blender doesn't support Arabic or Udru. I have fonts installed with OS support. but still, blender doesn't support it. Using a virtual keyboard to flip the letters wont help too, as they won't be joined as required. Only reasonable option left is to write them up in inkscape and import the svg in blender. (Convert your text to path , before saving svg file). i59.tinypic.com/2nis1gx.png $\endgroup$ – Ali Jibran Feb 18 '14 at 10:19
16
$\begingroup$

First of all, Blender does not support Right-to-Left text rendering, however there are ways to use a wide variety of character sets.

In a 3D text object:

The default Bfont has a very limited character set which does not include arabic.
To add arabic text to a 3D text object, you need to use a font that has the relevant glyphs (e.g. a unicode font). Once you find a font that contains arabic characters, you need to load it into blender.

Note that you cannot use bitmap fonts, as blender needs vector data for generating curves.

Loading a font:

You can load a font into blender from the Object data > Font panel:

  1. Add a text object ShiftA> Text

  2. With the text object selected, click the file icon for the appropriate styling (e.g. regular, bold, etc.) in Properties > Object Data > Font:

    enter image description here

  3. Navigate to a font file (.ttf .otf etc.) on your system and click Open Font:

    enter image description here

The font should now be used for the active text object.

Entering characters:

If you don't have a keyboard that has Arabic characters, here are some alternate ways to input text:

method one:
1. Select the text object and enter edit mode Tab. You should see a bar appear that indicates the location of the cursor:

enter image description here

  1. Delete the existing characters (Backspace) and enter a character. You should see a text field appear in the Redo menu at the bottom of the Tool Shelf (T in the 3D view):

    enter image description here

  2. Select the text box and paste the your text into it, then press Enter:

    enter image description here

    Note that you can enable International fonts in User preferences > System to display arabic charecters in the UI, making the arabic characters visible in the text field:
    enter image description here
    More about this later.

Method two:

As mentioned by kivig, there is a Paste from file feature.

  1. Select the text object and enter edit mode (Tab)

  2. Click Paste file in 3D view > Header > Text:

    enter image description here

  3. Navigate to a text file containing the text you wish to put in the text object and press Paste File.

In the Interface:

You can enable International Fonts in CtrlAltU> User preferences > System to display arabic characters:

enter image description here

This also enables options to translate the UI into many languages, including arabic. See the wiki for more details:

From version 2.60, Blender supports international fonts and a range of language options for the Interface and Tooltips. To enable it, open the User Preferences window, System tab, and toggle the International Fonts option in the bottom right-hand corner.

This displays three new settings:

  • Language
    drop-down menu where you can select your preferred language.

  • Interface
    to translate the User Interface itself (e.g. controls and menus).

  • Tooltips
    to translate tooltips.

$\endgroup$
  • $\begingroup$ Method two seems being dropped in 2.70? $\endgroup$ – Leon Cheung Mar 25 '14 at 12:19
  • $\begingroup$ @LeonCheung It was apparently moved to the "edit menu", but I'm not sure what that is.. $\endgroup$ – gandalf3 Mar 27 '14 at 6:23
  • 1
    $\begingroup$ In case you're using Blender 2.80, the "International Fonts" checkbox has been replaced by the checkbox in the "Translation" header in Edit > Preferences > Interface. Took me some time to find it. $\endgroup$ – Ray Jun 14 at 14:24
4
$\begingroup$

Another way is to type/load texts in Text Editor, then Edit>Text To 3D Object.

enter image description here

However, As you see from the image, the order for arbic characters is actually flipped. RTL editing/inputting hasn't been supported yet. You have to type / convert all characters flipped per line before that. (There is a very old solution for this, in case it may help some.)

$\endgroup$
0
$\begingroup$

Well for better results of text other than English I would advice you make a SVG file with inkscape and then import it in Blender.

$\endgroup$
0
$\begingroup$

Another way is to use Inkscape to create a font and save it as a .svg file. Then in Blender, enable the .svg import addon and import the .svg file that you saved.

$\endgroup$

protected by David Dec 19 '14 at 18:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.