1
$\begingroup$

enter image description here

This pizza waffle donut sandwich doesn't look so good with these strange shadow artifacts. What can I do to remove them?

$\endgroup$
  • $\begingroup$ This is a manifold mesh. When I turn off the bevel modifier they go away. Is this a problem with the bevel modifier? $\endgroup$ – clickbait Nov 19 '17 at 19:04
  • 1
    $\begingroup$ Does your mesh have any faces with more or less than 4 sides? $\endgroup$ – Brenticus Nov 19 '17 at 20:42
  • $\begingroup$ Yes it does.&nbsp $\endgroup$ – clickbait Nov 20 '17 at 1:03
  • 3
    $\begingroup$ Then my guess is the bevel modifier is causing some weird n-gons or tringles, and those are causing the weird shading. Try turning on auto smooth in the mesh properties tab and see if that clears it up. Getting rid of the n-gons would be the best solution, but would involve more work. $\endgroup$ – Brenticus Nov 20 '17 at 1:55
  • 4
    $\begingroup$ @downvote-flagger To get more interest in your question you should add more meaningful detail as to the issue. For example, you have mentioned the shadow artifacts but it’s not clear to someone reading this exactly what artifacts you mean (I guess it’s the vertical lines on the edges of the waffle). Your comment indicates that it seems to be the bevel that is causing - so edit question to mention that and show before/after images that make it clear as to the difference. Could also include wireframe to show geometry. A detailed and thought out Q will encourage interest and well written Answers. $\endgroup$ – Rich Sedman Jul 1 '18 at 8:06
4
+50
$\begingroup$

My guess - The bevel modifier will try to bevel every edge, depending on the bevel setting... if the "limit" setting is set to "none" then it will try to bevel all edges, even the ones running through an area that should be flat. This can create unwanted "wrinkles" or as it tries to create indentations wherever you have extra edge loops vertices.

For example, in the pic below, the right side of the cube has no edge loops so its bevel looks clean, but the left side's bevel has little dents from all those extra edge loops.

Bevel Issue

If you have extra cuts like this that aren't doing anything, you could remove some just to keep a cleaner mesh. But even so, there are always going to be extra cuts in your mesh, it's necessary to make modelling easier. So try playing around with limit options on your bevel modifier.

If you can't find a limit method that works only on the desired areas, you may have to apply a bevel manually by selecting the edges you want to bevel, and pressing ctrl+B. Be careful though, this is hard to undo if you decide later you don't like the bevels, and they make the mesh more complex, so it'll be more of a pain to work with. In fact, before applying bevels this way, you might want to make a complete copy of your mesh, and move it to a 'trash layer' as a backup, in case something goes wrong.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.