1
$\begingroup$

I'm not completely happy with the way particles work in blender for my particular needs and I have previously programmed particle simulations from ground up in Grasshopper and have some basic knowledge of python, so in theory, I should be able to write my own addon the way I'd like it to behave, I'm fairly new to blender though, so I don't have an estimate of how much you can access using the api. Would it be possible to use python to add another type of particle sim to the already existing emitter and hair types using an addon, or would this require a change to blender's source code? Thanks in advance.

$\endgroup$
4
$\begingroup$

I don't believe you can use python to add a new particle simulation type. While you can use python to access the particle system data such as particle location, I don't think you will have any luck altering the particle positions.

Before you start coding yourself I would suggest looking at sverchok and animation nodes. There is an introduction to animation nodes here and you will find blendersushi has many videos of experimenting with both addons. If they can't accomplish what you want to do, they may be a starting point for your own project or maybe you could contribute your own custom node to one of them.

$\endgroup$
  • $\begingroup$ been checking out Sverchok, looks promising on the videos, but I can't get it to work. I get this error message, when trying to activate the addon: import error: no module named 'sverchok.utils.geom' any idea what to do? $\endgroup$ – ivan Jun 25 '17 at 16:14
  • $\begingroup$ Are you downloading the zip and opening that in blender's prefs? or unzipping and installing manually? Have you tried master or a tagged release? $\endgroup$ – sambler Jun 25 '17 at 17:49
  • $\begingroup$ I tried both ways, installing the zip from the preferences and manually adding it to the addons folder, got the same result both times. I only found the master release $\endgroup$ – ivan Jun 25 '17 at 18:49
  • $\begingroup$ Just under the description at github you will find a link called releases which lists tagged stable releases that you can download. $\endgroup$ – sambler Jun 27 '17 at 2:05
  • $\begingroup$ ok, I found the culprit. For a scripting tutorial, I disabled blender's bundled python and was using a newer system-level version. after re-enabling bundled python, sverchok seems to work. $\endgroup$ – ivan Jun 27 '17 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.