2
$\begingroup$

I’ll try to explain the issue as best as possible, I’ll attach some pictures to better explain the problem. I have noticed that the more “lights” are introduced in a scene (both interior and exterior) the more the intensity of each lamp is reduced. I’ve notices the same issue with HDRI images. Again, adding more sources of light into the scene, results in a decreased intensity of the HDRI image itself. Clearly, the problem becomes extremely limiting especially in situations where multiple sources of illumination are required. In the attachments I’m showing the aforementioned issue, as you can see the source of lighting (in this case a simple Point lamp) decreases its intensity as the number lights increases. On every picture I’m adding one or more lamps.

enter image description here

enter image description here

enter image description here enter image description here

enter image description here

enter image description here

$\endgroup$
1
  • 2
    $\begingroup$ Can you try rendering again without clamping? That could be the cause for your issues but not 100% sure. $\endgroup$ – Gottfried Hofmann Feb 13 '17 at 16:35
3
$\begingroup$

The default "Path Tracing" integrator is coded so that for each sample, it will bounce light from a randomly-chosen lamp.

My suggestion is that you change the integrator to "Branched Path Trace", which you can change from the Sampling sub-tab.

Using Branched PT will make cycles take bounces from every light for each sample. This comes at the cost of increasing render times, but with the added benefit of reducing noise.

More info here: https://docs.blender.org/manual/en/dev/render/cycles/settings/integrator.html

EDIT: As a further note, Blender 2.79 will feature probablistic termination of lights based on contribution. Basically, it will randomly skip sampling from lights if their contribution to a sample would be below a certain threshold, causing it to spend less time computing bounces for lights which make little or no difference for a given sample. This provides speed gains in complex lighting setups, particularly where some of the lights are distant or occluded. More info here: https://developer.blender.org/rB26bf230

$\endgroup$
1
$\begingroup$

Well, first of all thanks for answer! In another discussion came out that the problem was due to the clamping, as indeed @GottfriedHofmann supposed.

Stefan Werner write:

"Try setting the clamp direct/indirect render settings to 0, that might make it go away. Stochastic sampling of many lights can lead to very bright individual samples, and when those samples get clamped before added to a pixel, energy (light) is lost."

...and again:

"Setting clamp to 0 does not make fireflies. Setting clamp to values other than 0 imposes a maximum brightness limit on individual samples. In many cases, limiting that brightness hides fireflies, but in cases like this, it can take away important contributions. A simple case to demonstrate this is if you take an object with a bright and sharp specular highlight and have that reflection be blurred either by depth of field or motion blur. Setting a clamp value on direct light very quickly dims what otherwise is a bright spot/streak. With many lights and path tracing, the following situation takes place: In standard path tracing, only one light is being sampled per pixel sample, all other lights are ignored. To compensate for that, the contribution of that light must be divided by the probability of that light being sampled, that is, divided by the number of lights. With 100 light sources, that means any given light source will be considered for only 1 in 100 pixel samples, but its contribution to that sample will be 100 times that of what it would be if it were just one light source. When that sample is now being clamped, this brightness gets limited and the appears darker than it should be."

I think that Stefan has nailed the point, the problem in that and, i think, in many other scenes with a lot of light source should be the clamp. In particular, the one that contributes the most at this issue is the "direct clamp". As Stefan says, it isn't the "0 Clamp" that produce fireflies, contrarily, the scope of Clamp is to avoid it. But in this particular case, increasing the number of light sources seems to influence the overall intensity of each light. However, the most fireflies seems to come from indirect bounces, so I resolved the intensity issues in this scene setting only clamp direct to 0 and leaving the indirect clamp to 4.

As @Gottfried suggest, I've rendered again the scene with direct clamp set to 0. I'll attach an explaining screen.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.