1
$\begingroup$

I tried to render my keyboard and it renders with Scene World. I tried to change the lighting from Scene World to HDRI (with HDRI it looks good (1)), but then it still ended up a mess.

Where is my mistake, can anyone help me, please?

Viewport, without Scene World or Scene Lights, looks good and I need to render it: enter image description here Render: enter image description here

I tried to apply these settings to make all the lighting in the rendering look like the first image (viewport), following advice from the Internet.

enter image description here

What I got after trying to solve the problem with 3rd Image: enter image description here

Where is my mistake, can anyone help me, please? I just want my rendering to look like the first image (Using HDRI City.exe instead of Scene Lights or World Scene)

$\endgroup$
3
  • $\begingroup$ You need to enable Scene Lights and Scene World to see what the render will give, otherwise you'll see a scene without the effects of your lights and with the effect of one of the default HDRI, not the HDRI you're using in your World material, so first thing reactivate these 2 options. If you need to remove your lights because they are too powerful, remove them for real or make them invisible in the Outliner. If you need another HDRI, choose another, if you need to make it darker, lower down the Background strength value. If it still doesn't fix your problem, share your file $\endgroup$
    – moonboots
    May 29, 2023 at 6:09
  • $\begingroup$ @moonboots dropmefiles.com/6ayRG Tried to follow your advice and background strength helped a little bit, but still, keyboard's lighting too hard on me. $\endgroup$ May 29, 2023 at 14:43
  • $\begingroup$ Oh ok it has to do with your Color Management settings $\endgroup$
    – moonboots
    May 29, 2023 at 15:23

1 Answer 1

0
$\begingroup$

It's caused by your Render > Color Management settings, switch back to the default ones, at least make sure that it doesn't over-expose your scene (Exposure value), here are the default settings (you can right click on the value to reset the value):

enter image description here

$\endgroup$
2
  • $\begingroup$ Big thanks, man! I don't know if I can somehow give you a like or +1 or something like that but thank you! $\endgroup$ May 30, 2023 at 10:21
  • $\begingroup$ Yes actually if the answer is correct you can mark it as correct (check icon on the top left of the answser) ;) $\endgroup$
    – moonboots
    May 30, 2023 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .