3
$\begingroup$

I'm trying to bake Cycles materials to a texture, for use in a different program. The issue is, whenever I bake the materials to a texture, the result is far darker than the original version.

This is it using Cycles materials:

With materials

And this is it with a texture. No other changes were made other than changing it from materials to a texture.

With texture

The second hat is dramatically darker than the original. How can I fix it?

These are the baking settings I'm using.

Bake setup

Any help would be much appreciated.

EDIT: Here's a link to the .Blend file of the hat. The texture is packed in with it, but if you need it separate, let me know.

https://www.dropbox.com/s/pvfrixxsd0p1atb/hat.blend?dl=0

$\endgroup$
  • $\begingroup$ Can you post the .blend and / or the newly baked textures? If it was baked properly, then you should probably just turn on "Shadeless" in the baked hat's material settings. $\endgroup$ – Coby Randal Mar 31 '16 at 23:13
  • $\begingroup$ I'm doing this in Cycles, and I don't think Cycles has a Shadeless option like Blender Internal does. I edited the question to include a link to the .Blend file, though. $\endgroup$ – Ninten1 Apr 1 '16 at 2:01
  • $\begingroup$ For shadeless in cycles you would use an emission node that is only applied if it's a camera ray using the light path node. $\endgroup$ – coCoKNIght Apr 1 '16 at 8:00
4
$\begingroup$

The way I found to do this is to set your cycles settings this way:

  1. Under Render Properties
  2. Under Bake
  3. Change "Bake Type" to "Diffuse".
  4. Select the "Colored" button, while disabling "Direct" and "Indirect"

I used Blender 2.78 by the way. Hope that helps!

Blender 2.78 Cycles Color only / Shadeless

$\endgroup$
  • $\begingroup$ For an explanation of why this works: the direct and indirect options are baking lighting information as well as just raw surface colour. $\endgroup$ – Sazerac Oct 11 '17 at 6:35
0
$\begingroup$

For those still bumping into this problem (I did)

Try switching the direction of the normals once or twice. Even if it looks all right. Somehow that helps. (not sure why).

And experiment with very low detail 256x256 to see if it works all right.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.