I have a recent problem that prevents me from using windows scripts for render queue on my desktop workstation.

The commands work, but the only problem is that it doesn't chain the next command to render the list. This is a test script in Render_Local.bat file:

cd "C:/Program Files/Blender Foundation/Blender 3.6"
blender -b "C:/Users/Utilisateur/Documents/Test/testRenderQueue.blend" -a
blender -b "C:/Users/Utilisateur/Documents/Test/testRenderQueue02.blend" -a
cmd /k

The test is very simple, the first rendering works but once finished it doesn't launch the second.

enter image description here

The same test on my colleague's PC works perfectly.

That's why I think the problem is with Windows or my Blender user settings.

I tried to deactivate many addons, re-install, etc...

Another clue: I didn't have this problem a while ago. I don't know if it started when I reinstalled a new version of Blender. Does anyone have any idea how to solve this?

  • $\begingroup$ It works for me as well. It is almost impossible to pinpoint the problem, there are too many factors involved that can affect this outcome. I would first start with a simple setup. Create 2 simple files and see if that works. Maybe something with your system resources like ram, cpu, gpu? Or differences in installed addons, or graphic driver problem, or scene complexity. $\endgroup$
    – Harry McKenzie
    Commented Sep 7, 2023 at 3:40
  • $\begingroup$ yes, it's a test file in this case. I thought for a moment that it was coming from plugins, but I also tried disabling them. The crazy thing is that sometimes it works, but very rarely... $\endgroup$
    – Pomess
    Commented Sep 7, 2023 at 16:06


You must log in to answer this question.

Browse other questions tagged .