So I installed official Blender dmg and downloaded the experimental package "CAD Sketcher" as of 20 July 2022 ZIP-file.

But I fail to install the Add On. When I try to activate the Add on I get a ERROR log hinting at it fails to find the py_slvs module.

enter image description here

  1. I HAVE installed the py-slvs module using pip (BUT I suspect I need to have blender install it - ONLY, I do not get or find the option to do so)?
kjell-olovhogdal@Kjell-Olovs-Mac-Pro ~ % pip install py-slvs 
Requirement already satisfied: py-slvs in /usr/local/lib/python3.9/site-packages (1.0.4)
kjell-olovhogdal@Kjell-Olovs-Mac-Pro ~ % 
  1. I HAVE tried restarting Blender (to have it use fresh system preferences) and I HAVE restarted macOS (to ensure I have all things know everything).

So - How do I make Blender interop as required with Brew installed Python 3.9 and have Add On "CAD Sketcher" work as intended with py_slvs


1 Answer 1


I solved the Issue myself - although I suspect I was supposed to be able to not get the error in the first place, but an option to install py-slvs from within Blender itself?

  1. I Figured out that Blender uses its own Python installation, on my macOS at path '/Applications/Blender.app/Contents/Resources/3.2/python/bin' (This path was spelled out in the original ERROR, see my ininitial question above)

  2. I could now open a Console and instruct "Blenders Python Framework" to install the py-slvs (first upgrading the pip version as a warning told me to do)

Last login: Thu Jul 21 20:54:53 on console
kjell-olovhogdal@Kjell-Olovs-Mac-Pro ~ % /Applications/Blender.app/Contents/Resources/3.2/python/bin/python3.10 -m pip install --upgrade pip
Requirement already satisfied: pip in /Applications/Blender.app/Contents/Resources/3.2/python/lib/python3.10/site-packages (21.2.4)
Collecting pip
  Using cached pip-22.2-py3-none-any.whl (2.0 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 21.2.4
    Uninstalling pip-21.2.4:
      Successfully uninstalled pip-21.2.4
Successfully installed pip-22.2
kjell-olovhogdal@Kjell-Olovs-Mac-Pro ~ % /Applications/Blender.app/Contents/Resources/3.2/python/bin/pip install py-slvs     
Collecting py-slvs
  Downloading py_slvs-1.0.4-cp310-cp310-macosx_10_9_universal2.whl (404 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 405.0/405.0 kB 4.7 MB/s eta 0:00:00
Installing collected packages: py-slvs
Successfully installed py-slvs-1.0.4
kjell-olovhogdal@Kjell-Olovs-Mac-Pro ~ % 
  1. I was now able to activate the Add On "CAD Sketcher" in Blender OK :)

enter image description here

==> BUT - Please if someone knows a "better" way of avoiding the error in the first place (or if there is an error in Blender for macOS that needs attention), feel free to update the response to my original question.

Thanks :) !


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .