1
$\begingroup$

I am trying to use Blender GIS from this Repo: https://github.com/domlysz/BlenderGIS

I have installed it properly and it is running in my Blender 2.79 on a MAC OS X 10.13.1 High Sierra.

When I attempt to click on Basemap (On the left pane > GIS Tab > Basemap), I expect a dialog, but instead I get this error:

no imaging library available please install python GDAL or Pillow module

So I proceeded to install those modules, eventually realizing that they apparently need to go in the Python packages directory for that specific Blender version, as per this solution found here In my case, the library is located within the application itself, which I accessed through right clicking the Blender icon and then Show package contents... with the complete path being like this.

/Applications/Blender/blender.app/Contents/Resources/2.79/python/lib/python3.5

I then used these instructions to install in the specific directory above.

So now that I have installed Pillow and GDAL in this directory using pip, I start Blender and the same error comes up.

What am I missing?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.