1
$\begingroup$

I'm new to blender and doing the donut tutorial. When I try to select vertices to move on one side of an object, sometimes it grabs the vertices on only the face that is visible, sometimes it grabs vertices from other faces as well. After testing this and trying many solutions, I've noticed that it seems to be dependent on whether my selection extends beyond the boundary of the visible mesh.

For example, when my selection box is between vertices on the visible face it functions as desired: selection box is in between vertices

selected vertices moving as desired

however, when my selection box extends beyond the vertices on the side of the mesh i intend to select on, vertices from other faces are also selected and moved:

selection box includes vertices but extends beyond the edge of the visible mesh

image shows that the highlighted selected vertices appear to be the ones within the prior selection box

however, upon moving the vertices, several ones that were not on the visible face or highlighted previously are moved as well

I added a lot of pictures because I'm not certain I'd be able to properly explain without them. Also, in case it's important, besides the camera and light the only objects are the donut and the icing (which is what i'm trying to edit). The 'icing' is just the top half of the donut, duplicated and separated into another object, which was shrink-wrapped and snapped to the surface of the donut.

My question is: is there a way to be able to move only the vertices on the face I'm looking at without having to be so cautious about how I select vertices?

I've tried enabling and disabling proportional editing and snap, removing and adding modifiers, having selection on tweak or selection box, closing and re-opening the program, toggling x-ray on and off, adjusting transformation orientation... none of them worked.

$\endgroup$
1
  • 2
    $\begingroup$ This is just how selections work in Blender. When you enter an object's edit mode, only the object itself can obstruct its other parts to be selected. I don't know of any options to prevent that but you can select both the doughnut and the icing before going to edit mode and the doughnut will block the other vertices to be selected and then you just unselect the parts of the doughnut with SHIFT+L. $\endgroup$ Mar 29 at 5:01

1 Answer 1

1
$\begingroup$

If you have something like this:

enter image description here

it is pretty clear that you don't see all vertices which exist.

But you can select "unseen" vertices and i think this is what makes it difficult for you:

enter image description here

So I selected here 8 vertices, but when selecting them i only saw 4 selected.

You can improve the visibility by just clicking here: on Cage

enter image description here

enter image description here

enter image description here

Note: One more remark: with x-ray toggled off Blender only selects the vertices which are nearest to the viewer and directly visible. With x-ray toggled on, Blender selects all vertices until infinity in view direction in the range of your selection:

enter image description here

If you only want to select parts of your mesh, e.g. the icing is on top (but separated from the donut - i hope it is that way), then you could select the icing, press L H, and then change your donut as you want:

enter image description here

L -> select linked vertices H -> hide vertices

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.