0
$\begingroup$

Yes, I know that this has been answered before because I used an answer yesterday and it worked perfectly. Today it does not.

So.

Select Object.
Enter Edit Mode by hitting TAB.
Select a Face on the object. Only one face is selected.
Add a New Material.
Give material a basic color.
Click Assign.

Yesterday this would make the selected face the selected color and I had several colors on each object. Today the entire object takes the selected color. I have hunted for a solution for two hours but nothing seems to work. I am using Blender version 2.9.

Can some please give me any definitive answer as to why this should be happening, and if possible how to correct it. Nothing has changed in Blender, I have created a new project, and suddenly this problem before I even get started.

Many thanks

Max

UPDATE

An interesting development: I tried again today, starting with a new file, same procedure as before and with the same result, the entire block is colored rather than the selected face.

However ... I saved this file, closed Blender and got a coffee. I then re-opened Blender, loaded the file and the block now appears with the previously selected and colored face the correct color.

Adding a new block, selecting a face and setting a new material now works exactly as expected and so far this has continued to work correctly.

I have closed Blender, started a new project and suffered the same issue, however, saving, closing, re-opening and loading seems to fix this problem, and when re-loading any project everything works as expected, which means the issue is ONLY with a new project.

I'm stumped, but things are working now, although I have no idea why. Ideas and discussion welcome, but currently, aside from this weirdness, everything is working as expected.

$\endgroup$
4
  • 1
    $\begingroup$ Please add a blend file that demonstrates the problem. (How to add a blend file) $\endgroup$ Oct 19, 2021 at 19:24
  • 1
    $\begingroup$ Please add some screenshot of the issue and your material settings too. Are you adding more than one material for your new project or is it just one? $\endgroup$
    – Emir
    Oct 19, 2021 at 19:34
  • $\begingroup$ No point in a blend file, its just a new file with a box in it. Iv not created any other files since yesterday when this worked, and Iv not edited any settings. As for the number of materials, its one, the first one. I tried adding several, but never bothered to save because nothing worked. $\endgroup$
    – MaxVK
    Oct 19, 2021 at 20:06
  • 1
    $\begingroup$ If I read this correctly, you only have a single material on the box. But isn't that the normal default behaviour that - when you only have one material - it is automatically assigned to all faces? You have to add at least a second material to assign it to specific face(s). Or do I misunderstand the question? $\endgroup$ Nov 24, 2021 at 12:14

1 Answer 1

0
$\begingroup$

This is a bug, therefore there isn't any help we can give you. Disable all your addons, reinstall blender.

If it persists, you may also submit it to Blender's bug tracker.

$\endgroup$
9
  • $\begingroup$ Looks like it might be a bug tracker then, because I have no plugins and Iv restarted quite a few times. Thanks. $\endgroup$
    – MaxVK
    Oct 19, 2021 at 21:19
  • 2
    $\begingroup$ It isn't a bug. You have to create a material with 'New' first which becomes the base material for the object. Then click the '+' button to add another material, set its colour, and then assign that colour to your selected face. $\endgroup$
    – John Eason
    Oct 19, 2021 at 21:22
  • $\begingroup$ Did you not read the original post? $\endgroup$
    – MaxVK
    Oct 19, 2021 at 21:32
  • $\begingroup$ How many material slots are displayed in the box on the right when the whole object changes color? $\endgroup$ Oct 19, 2021 at 22:11
  • $\begingroup$ Number of materials tried, starting from zero up to four. Exactly the same result. $\endgroup$
    – MaxVK
    Oct 20, 2021 at 9:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .