0
$\begingroup$

One plane with one subdivision= 4 faces.

In the material properties, I color with say, blue. Then in edit mode, I assign 1 or 2 faces to say, yellow. Then blue faces become transparent. If blue is at the top of the stack, then blues are visible but yellow becomes invisible. If yellow is at the top of the stack, yellow becomes visible but blues, are invisible. Each material is linked to object.

I tried resetting to factory defaults, and started a new blend file, same result. Using EVEE. In cycles renders well, but the only viewport shading that shows correctly is rendered.

Had no problems when using 2.79.

Laptop computer with 4 gigs ram, no GPU’s, Windows 7. 2.83 (released June 3, 2020). NVIDIA GeForce GT 330M. I just found at https://developer.blender.org/T71576 that the problem apparently is older graphics cards. If this be so, when might the developers have a solution that we can use?

Noticed similar problem in can't use different materials in one object (blender 2.82a). But the answer (Go out of edit, then back in) did not solve the problem.

$\endgroup$
0
$\begingroup$

This might sound stupid but did you check you're not in x-ray mode?

If not, check the Blend Mode and Shadow Mode in the settings of the material tab. Make sure they are both set to "Opaque" if you're not using transparency otherwise materials can appear to slip through each other.

$\endgroup$
2
  • $\begingroup$ @EANIX Not in x-ray and Blend mode and Shadow mode are set to opaque. $\endgroup$ – Roberto Collins Lazo Jun 13 '20 at 0:03
  • $\begingroup$ @EANIX Your comments are not stupid, appreciate your thinking $\endgroup$ – Roberto Collins Lazo Jun 13 '20 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.