4
$\begingroup$

I have a question about the keyboard input handling of Blender.

I'm running Kubuntu 14.10, and set up my Caps Lock such that it acts like an extra Ctrl key (System Settings → Input Devices → Keyboard → Advanced → Caps Lock key behavior → Make Caps Lock an additional Ctrl)

Every application simply sees it as just another Ctrl key. Blender, however, now ignores the key altogether. Pressing Caps Lock + W acts as if I just pressed W. The Python scripting console also keeps typing in lower case after pressing Caps Lock, which shows that it's no longer interpreted as Caps Lock either.

This happens when running Blender 2.72b, as well as when I compile my own Blender from Git.

Who can help me solve this?

$\endgroup$
6
$\begingroup$

Apparently, the KDE settings aren't as "low level" as Blender's input system. This command, however, is:

setxkbmap -option ctrl:nocaps

It also makes Caps Lock an additional Ctrl, but at such a low level that Blender understands it too.

Source: http://www.emacswiki.org/emacs/MovingTheCtrlKey

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.