I remapped my keyboard (using KeyTweak) and now my "Caps Lock" acts as "Left Shift", "Left Shift" acts as "Left Ctrl" and "Left Ctrl" acts as "Caps Lock". It works on every other program that I tested. In Blender the "Caps Lock" (which acts as "Left Shift") does not work for any shortcut (the hotkey window just ignores my "Caps Lock" key presses), but works for typing text. On the other hand the "Left Shift" (which acts as "Left Ctrl") works.

Is there a way to solve this? I never created a script for blender and I don't know the API, but maybe I can emulate shift key presses via script or something like that?!

P.S I remapped the keys to reduce the wrist strain while programming, playing and modeling.

  • $\begingroup$ Blender as a built in keymap editor, although it won't solve your external rebinding, with a little work you could recreate your remapings directly inside Blender that would probably be less prone to conflicts reducing any problems you may encounter. $\endgroup$ Commented Mar 23, 2016 at 0:20
  • $\begingroup$ @DuarteFarrajotaRamos You mean the shortcut window under User Preferences > Input? If I try to rebind some shortcut by pressing "Caps Lock" (which acts as "Left Shift") nothing happens, but works for my "Left Shift" (which acts as "Left Ctrl"). $\endgroup$
    – William S.
    Commented Mar 23, 2016 at 3:45
  • $\begingroup$ That is probably a conflict between whatever application you are using to rebind keys and the way Blender captures keypresses internally. What I meant was using User Preferences > Input exclusively and rebind keys entirely from there instead of using another third party application which is bound to cause conflicts $\endgroup$ Commented Mar 23, 2016 at 5:32
  • $\begingroup$ The problem is that I can't just turn on/off the KeyTweak software since it changes the windows register keys (it requires a restart). This works fine with every other software, the problem is how Blender handles input (which I want to change). $\endgroup$
    – William S.
    Commented Mar 23, 2016 at 13:13

1 Answer 1


I found a software called AutoHotkey which send keystrokes to other programs and WORKS WITH BLENDER. Just restored my KeyTweak changes to default and restarted the PC, then I installed AutoHotkey and created the following script:

SendMode Input
SetWorkingDir %A_ScriptDir%

Saved and ran the script as administrator. Works perfectly.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .