1
$\begingroup$

I have used append many times, but recently it refuses to work. I suspect I know why - it's a bug related to animation and/or armature.

I would love to know if anyone has any secret workarounds. The problem is 100% reproducible here - I cannot append any collections with armature and models in them. They all return "nothing indicated" as the error message.

It may also have to do with collections...I can sometimes get the project to open in append (in order to choose items) but selecting the relevant collections returns with the error.

Also, very often simply choosing any other item from the append list - cameras, or mesh say, there is no error message and nothing is brought in.

Copy and pasting of collections never works as expected. If I select the collection, and paste it in to the scene collection on my view layer, the collections are not pasted, but parts of their contents (not all), and never organised into their collection. The only work around I have atm is to go into the source file and delete everything else before copying.

We might suspect a corrupt file, but this is in multiple files including brand new ones. It also occurs both on Linux and Mac systems (I am running 3 systems), and the problem occurs there as well. I'd love to know what the problem is and if there are any work arounds. It's a really big problem.

$\endgroup$
5
  • 1
    $\begingroup$ Exporting as FBX is a reliable solution ONLY when you need just the very basic data (raw meshes, deform bones with no controllers nor mechanics, raw animations & hierarchy). If you need anything else, then it's only one of the last solutions if anything otherwise fails. Have you ttied with different Blender versions? Different files? Different assets? If there's always an issue no matter what, report it as a bug Otherwise, I'd suggest to share your .blend file so we can see what might cause the issue. $\endgroup$ – L0Lock Aug 5 '20 at 13:39
  • $\begingroup$ Thanks for the response. So far it is occurring in most blend files of which there is very very many. The problem for sharing is that most of the files are very big - between 1 and 2 Gb sometimes bigger. I actually have not tried with earlier versions - that's a good idea. You are also correct exporting via FBX is not feasible. To reproduce, add some Mixamo animations to your blend file and organise them into collections. Can you append those collections to a blend file? $\endgroup$ – DrIgnatiusCole Aug 5 '20 at 14:26
  • $\begingroup$ I tried to import a mixamo model & animation on v2.83.0 and 2.83.2 and I have no issue. Maybe try to upload your blend file on google drive or something, so we can see if it's your assets causing issues. $\endgroup$ – L0Lock Aug 6 '20 at 16:47
  • $\begingroup$ Hi there - here a link to a blend file from which I cannot append to other files. Open a new blend file then go to "append" and try to append the collections "Cogsworth" and "Dirigible". we.tl/t-8xq9KrT7ze $\endgroup$ – DrIgnatiusCole Aug 7 '20 at 8:20
  • $\begingroup$ I'm afraid I still can't reproduce the issue. $\endgroup$ – L0Lock Aug 7 '20 at 21:53
1
$\begingroup$

I discovered what the problem was - it's very simple and is just a result of a slightly confusing UI.

On choosing the file to append, the blue append entry field remains blue while it loads up the file...but to me it looks like nothing is happening. That's because it takes a while to load up the file - sometimes 15 to 20 seconds. I am hitting the append sign because I am not being given any feedback that Blender is working, and it is trying to append when I have not made a selection.

It was bound to be something simple.

$\endgroup$
0
$\begingroup$

I think opening files in two different Blender windows might be useful. You can just copy and paste between the two windows. It work for the most time

$\endgroup$
1
  • $\begingroup$ Thanks for your reply, but I am having problems with copy and paste as well. The collections will not copy and paste between blender files. What does work is to copy and paste from the viewport and then re-organise them back into Collections afterwards. $\endgroup$ – DrIgnatiusCole Aug 7 '20 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.