1
$\begingroup$

I am new to Blender and 3d modelling and I have created a scene with several meshes and textures/materials.

All materials are gltf compatible (Principled BSDF nodes with image texture and normal maps).

If I export them uncompressed everything works fine and I love it. But when I use export with compression enabled, all except of exactly one mesh in scene are simply dark (like there is no light).

If I separate the json gltf from the binary and have a look on it seems to be fine. All textures and materials are exported as expected.

Is it possible that the draco compression mess up the assignment of the textures to the objects? Are there known problems with draco compression in blender if several objects use the same materials?

While my own researching I tried different workarounds.

At first I used node groups as templates for materials which are only slightly different. This causes after draco compression that every mesh has its texture but without the impact of the node group.

I think the node groups are simply ignored. Ungrouping them leads to the problem described above.

Another thing I tried, was to export without compression and apply it manually with the gltf-pipeline package of the npm repos.

This solves the problem with the texture indeed, but causes some weird shapes in one of my meshes.

Decreasing the compression level or increasing quantization makes it better (maybe) but not crucial.

A big impact on the quality could only noticed if uv and normal data was excluded from the exported gltf. If I don't export these extra data from Blender the quality of objects which uses a subdivision surface modifier is very poor.

I would be glad about any hints or proposals to do it right.

$\endgroup$
1
$\begingroup$

Ok i got it. It is indeed a bug in the glTF-Blender-IO addon. See https://github.com/KhronosGroup/glTF-Blender-IO/issues/993. There is also a workaround described how we can solve this. So what stays is the hope that other people will find this solution a bit earlier than me and there will be a bugfix soon...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.