I'm having fun compositing some videos on Blender and it's awesome. However, when I'm done compositing a video and start rendering with both Compositor and Sequencer checked, the video renders with audio BUT no compositing effect that I added is rendered (only raw video and audio are rendered)

When I uncheck Sequencer and leave only Compositor checked, the video is rendered with the compositing effects that I added, BUT no audio is rendered! Why?

Here are some screenshots of my set up: enter image description here

  • 1
    $\begingroup$ I'm surprised nobody asked to see a screen shot of the VSE; but anyway, this is probably related to a VSE bug that was fixed in 2.93.4. If you show a screenshot of the VSE it would help. $\endgroup$ Sep 26, 2021 at 23:52
  • $\begingroup$ Did you ever solve this problem? I'm running into the same issue. $\endgroup$
    – jglasse
    Oct 19, 2021 at 18:07
  • $\begingroup$ @jglasse did either of the solutions answer your question? $\endgroup$ Oct 29, 2021 at 15:08

2 Answers 2


Does this solve your question?

enter image description here


Although the other answer helps, it doesn't include what you may need with the VSE (the audio setting will try to get audio from the scene). I was able to replicate your problem and resolve it with the VSE. Here are the essentials:

First, a scene with your compositing setup: Compositing nodes (doesn't need scene node)

Check the compositing checkbox but not the VSE.

Second, create a new scene (in 2.9x at least, a scene can't use itself in the VSE), open up the VSE. Add the original video - this will add an audio and video track. You can delete or hide the video track, but keep the audio (and be sure your frame rate matches! This syncs the audio). Then, add your first scene (which has your compositing setup) as a track above any other video. It will show your 3D camera view, but don't worry - as long as you check compositing in the first scene, you'll be fine.

VSE with audio track and first scene's track

Make sure the sequencer post-processing checkbox is checked for the second scene, and then render out the video. :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .