0
$\begingroup$

I've subdivided and extruded, then copied, rotated and joined the base shape to create a grooved frame. The center of mass is the center of the frame.

I've then added a cylinder to sit inside the groove. I tilted the grooved frame slightly so the cylinder will roll. The center of mass on the cylinder is correct.

I've given the frame the passive rigid body property and the cylinder active. Both set to mesh. This is what happens:

enter image description here

I tried all the stuff in this previous answer:

Rigid Body Problem - objects not colliding

Any help is much appreciated.

EDIT:

I went back and re-built everything using some of the suggestions and still no luck. Uploaded the .blend this time.

$\endgroup$
3
  • $\begingroup$ Consider adding an image with settings or uploading a sample file blend-exchange.giantcowfilms.com $\endgroup$
    – batFINGER
    Jan 19, 2020 at 6:58
  • $\begingroup$ Enable deactivation of the rigid body and the cylinder won't move. $\endgroup$ Jan 19, 2020 at 12:16
  • $\begingroup$ Thanks @batFINGER, edited the question to add. $\endgroup$ Jan 19, 2020 at 20:11

1 Answer 1

1
$\begingroup$

I find if I turn these settings up and turn sensitivity,Margin to 0 I get good results in similar simulations.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ It's still kind of wonky but it got much much better with the margin set to 0. I had avoided doing that because the field tells you not to. :/ Thanks! $\endgroup$ Jan 19, 2020 at 20:28
  • $\begingroup$ no probs. I downloaded and tried your file. I changed the cylinder to convex hull and made the box a mesh with margin zero. that had decent results! $\endgroup$
    – ydvisual
    Jan 20, 2020 at 2:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .