0
$\begingroup$

i have tried everything and it does not move as an dynamic active object. clear parent does not help. it has an "child of" object constraint:

armature belongs to a human armature. the influence gets zero at some point but seems that has no effect on the dynamic active rigid body object.

There is no passive object. at least not yet. the closest topic asked previously is this:

Object physics not working when moved with armature?

that says i have to parent the object, containing the active object. i have no "passive" objects to parent to something. the object is parented through constraint to the armature's left hand.

and it doesn't fix with applying scale:

Collision/Rigid body objects not moving an inch

and none of these helped:

Rigid Body Problem - objects not colliding

How do I Attach a Rigid Body to a Bone?

i have removed the "child of" and the object still is not dynamic. the "unlink" option at the context menu at the outliner of the linked object does not unlink it. With the "child of" constraint removed, it then can be unlinked through context menu, but still not moving when animated as a dynamic object. i have tested with a new file. results was that this odd problem occurs only when an item is linked to the armature (through any way), but the problem solves when item unlinked and removed from the armature as an linked object visually at the outliner. but in this blend file, doesn't work. it never moved as a dynamic object by any ways. my scene: pay attention to the dynamic-animated checkboxes for insert keyframe

EDIT: Same happens to any item. idk how but before fixed that a new item [a cube] got dynamic physics but i forgot how and never got it to work again. here is a video of what i do.

https://drive.google.com/file/d/1f2eI25hs11jH8Vm5zJzgwCeHA_Ywqpup/view?usp=sharing

EDIT: I got it to work with starting from frame zero. but still not working on the object that was used first in the scene. The video of the same method, performed on an appended and just one part of the desired model from a backup of the blend file, unlinked and no parents, constraints. scale of all objects applied later and had no effect:

https://drive.google.com/file/d/1uunsfdHul5KR2D0OBMXWEC20y8swkwBR/view?usp=sharing

$\endgroup$
0
$\begingroup$

FINALLY FOUND OUT THE SOLUTION: i have checked and tested anything, and saw that nothing, old or new, linked or not, objects, will not animate after frame 250. i could see the cache like down the timeline that stops after this frame. according to this page ( https://docs.blender.org/manual/en/latest/physics/rigid_body/world.html ), i have increased the Scene Properties/Rigid Body World/Cache/end from default 250 to the desired, in my case 1286, and started the whole animation from frame 0. and it cached all with the line below timeline and at last this was the result: pay attention to the right side, dynamic and animated keyframe checkbox.

Here it is:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.