0
$\begingroup$

I am trying to render some simple geometric form using freestyle in Blender. But parts of some edges are missing - even though I have marked freestyle edges. Does anyone know how to fix this?

discontinuous edges

edge settings

$\endgroup$
1
$\begingroup$

The issue seems to stem from the scale of the object. While you've set the unit scale down, it's still large in Blender units. I suggest setting the unit scale back to one and scale the object to the size in millimeter that you were intending. This results in correct freestyle edges.

enter image description here

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for the reply. Your solution seem to work. But it messes up the scaling when you import any other object. The freestyle line issue is seems to be resolved but it's started a new confusion regarding my understanding of the the unit settings in Blender 2.80... By the way, how did you change the scale without changing the object size? When I change the scale I have to scale the object down (by 1000th) also and re-frame the shot by moving the camera close. Did you do that or is there a better way? $\endgroup$ – saicode Jul 28 '19 at 18:44
  • $\begingroup$ @saicode you can adjust the scale in most importers, you just have to know in what dimensions it's stored and what dimensions your scene has. I did scale the object. First I've set the unit size to 1 so that it maps exactly to one Blender unit. Then I've adjusted the object size to the one it's supposed to in mm. The camera position needs to be adjusted, but the change is also relative to the scaling factor. $\endgroup$ – Robert Gützkow Jul 28 '19 at 20:49
  • $\begingroup$ @saicode I'm not sure if freestyle has a problem with unit scale not being 1, but generally I'd keep it at that value unless you really need the increased precision for small real world scale of object in mm or below. $\endgroup$ – Robert Gützkow Jul 28 '19 at 20:57
  • $\begingroup$ @saicode I just tested with a unit scale of 0.01 and adjusted scales, it works as well. It could be that the large distance ranges in Blender units in your scene result in a precision loss in the depth map which causes these artefacts in freestyle rendering. $\endgroup$ – Robert Gützkow Jul 28 '19 at 21:26
  • $\begingroup$ thanks again! when you are using metric system and want to use mm as the unit, I thought the rule was to make the scale factor 0.001 (basically 1meter/1000 = 1mm) - with this settings importing files from other programs (esp. CAD) is easy - it comes in the right scale and you don't have to apply anything at all. And it works flawlessly with every kind rendering - this is the first time I am am coming across any problem due to scaling factor. $\endgroup$ – saicode Jul 29 '19 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.