0
$\begingroup$

I'm trying to make a short 5 minute toon shaded starship scene with Blender Cycles. The ship(s) in the scene also have a toon outline created by two line sets, one thinner one set to only render on creases and edge marks and one thicker one set to only render on object contours. It looks good and like the way I want it to be, but when I render an animation (camera flyby) I notice that on some frames certain lines break. You can see that here: https://youtu.be/czazInaUevc

That looks pretty ugly. Is there any way this can be avoided or at least greatly minimized? Here's the scene's .blend file: https://drive.google.com/file/d/1ceVqcvQTiVrjOe-18zJdUkYJpaEqc1QP/view?usp=sharing

$\endgroup$
  • 1
    $\begingroup$ For the benefit of future users (and to make it more likely people will answer), can you include a screenshot of what you mean instead of a video? $\endgroup$ – Kirbinator Apr 10 at 15:02
  • $\begingroup$ Not in this case as it is only noticeable (or only happens) in animations. $\endgroup$ – Tattorack Apr 10 at 15:52
1
$\begingroup$

You have to adjust your model (topology) to be better compatible with freestyle.

Two problem of your geometry are

intersections and sharp angles left: intersections; right:sharp angles

Freestyle isn't designed to work with intersections. An intersection will remove other lines if freestyle wrongly thinks that a line segment is occluded (even though it may be only partially occluded).

occluded parts

If you are using Smooth Shading and Subsurf Modifiers, you should consider checking Face Smoothness. The manual is quite vague

When enabled, Smooth Shading will be taken into account for edges calculation.

However, I have found that some edges with wouldn't be connected, are connected with Face Smoothness enabled.

face smoothness

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.